Ask Your Question
1

Why does nemo eats up so much CPU (whole core on IDLE)

asked 2014-07-08 08:42:30 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

As you can see on the screen-dump I' using cinnamon and nemo to replace the nearly unusable (new) gnome 3 environment on FEDORA20

[juergen@nadhhlt yaze-ag-2.30.3]$ uname -a
Linux nadhhlt 3.14.9-200.fc20.x86_64+debug #1 SMP Thu Jun 26 21:23:03 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

top - 15:35:59 up 20:05,  5 users,  load average: 0,44, 0,32, 0,26
Tasks: 251 total,   1 running, 250 sleeping,   0 stopped,   0 zombie
%Cpu(s):  1,7 us,  1,0 sy,  0,0 ni, 96,3 id,  0,3 wa,  0,2 hi,  0,5 si,  0,0 st
KiB Mem:  16325692 total,  8225136 used,  8100556 free,   888440 buffers
KiB Swap: 18440188 total,        0 used, 18440188 free,  2304068 cached
PID to signal/kill [default pid = 7031] 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND     
 7031 juergen   20   0 1866300 268644  27608 S  14,2  1,6   5:21.14 nemo        
 ###########################################################
 1249 root      20   0  277828  41716  25388 S   3,6  0,3  50:19.82 Xorg        
 2619 juergen   20   0 2152824 398172  47660 S   1,3  2,4  18:22.16 cinnamon    
 9583 juergen   20   0  814228  23500  14316 S   1,0  0,1   0:48.54 gnome-term+ 
 1145 root      20   0    4292    596    504 S   0,3  0,0   0:09.58 rngd        
 1836 mysql     20   0  849568  84788   7840 S   0,3  0,5   1:18.99 mysqld      
 6142 juergen   20   0  123664   1708   1144 R   0,3  0,0   0:17.26 top         
    1 root      20   0   51068   7032   3856 S   0,0  0,0   0:06.34 systemd

But nemo takes a whole core and eats up a lot of system-resources in IDLE mode (only the desktop items will be handled, no file browser or other things are open) If nemo is running on the background, the core temperature comes um near 100°C in few minutes. After I killed nemo (desktop-buttons disappearing) the temperature degrees to 50-60°C and the system turns back to normal IDLE CPU load immediately. Any Idea or Hint?

Sincere Juergen

edit retag flag offensive close merge delete

Comments

Make sure that all Nemo windows are closed AND make sure that no nemo processes are still running (check if it is still running using pgrep -l nemo. Then, open a command prompt and run nemo from there. When it takes lots of CPU, check the command prompt to see if it is printing any (error) messages repeatedly. You can also check system logs to see if any errors are reported (run journalctl -lf before running nemo and let it keep running and check if any errors are reported when you run nemo).

hedayat gravatar imagehedayat ( 2014-07-08 10:43:39 -0600 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-07-05 09:04:23 -0600

I had a similar issue -- nemo eating CPU, not much RAM though. But the .cache wasn't the issue. What magically fixed it was: clean up my Desktop by moving every file except .jpg, .png, folders and .desktop shortcuts out of my Desktop/ folder. (also I manually killed nemo, launced natilus to try it out, then killed nautilus and re-launched nemo, but that probably didn't influence the actual fixing)

I got that problem after force-copying a backup of my home dir (all of it, even hidden .something folders and files ... silly me) onto the homedir of a freshly installed ubuntu.

edit flag offensive delete link more
0

answered 2015-01-06 13:50:04 -0600

I had a similar issue and it turned out to be a permissions issue in my home folder.

~/.cache/thumbnails had owner/group set as root:root.

This would be fine if nemo ran as root, but on my system, it does not.

nemo ended up spending massive amounts of compute and memory building thumbnails that it could never save.

I ran chown -R me:me on the directory and nemo calmed down immediately.

This is what pointed me in that direction: https://github.com/linuxmint/nemo/issues/777

edit flag offensive delete link more

Comments

Thank you so much! This was my issue as well. Smh.

gshereme gravatar imagegshereme ( 2015-10-15 19:53:02 -0600 )edit
0

answered 2014-07-09 04:12:54 -0600

NickTux gravatar image

I can think of two cases here:

  • You have been logged in to Cinammon 2D by mistake or without to notice.

This can lead to 100 CPU usage, because at Cinammon 2D the CPU handles all the graphics.

echo $DESKTOP_SESSION

can help you determine the current environment (that is running).

  • It's a bug and you should report it.

I'm using Cinammon at my F20 box and I don't have such problem(s). But, I'm using the version from the fedora-updates-testing repository. If this is a bug and you are using Cinammon/nemo from the stable repository, then it could be fixed in a newer release. So, another workaround here coulde be to enable the updates-testing repository and install nemo (or update the whole Cinammon DE) from there.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-07-08 08:42:30 -0600

Seen: 3,646 times

Last updated: Jan 06 '15