Ask Your Question
1

Brightness change hotkeys not working

asked 2014-07-05 13:22:27 -0600

SudoHalt gravatar image

updated 2014-10-01 22:55:04 -0600

mether gravatar image

Hello,

I just installed Fedora 20 on my laptop, and one of the first things I noticed is that I was not able to change the brightness using the keyboard hotkeys Fn + F6 (decrease) and Fn + F7 (increase). Note that when I use any of those keys, the brightness indicator appears, but nothing else happens, the indicator cannot even go to the right or left. This is the first linux distribution I tried that has this problem.

I can change the brightness only by going to the notification area, or through power options. Any help?

EDIT: Here is the output of the command. I am sorry, I had trouble inserting the code, so here is a picture:

Command-line Output

edit retag flag offensive close merge delete

Comments

Welcome to Ask Fedora. What is your graphics card ? Also, open a terminal and paste here the output of this command for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/max_brightness; done . Please, edit your question and add the output there at the appropriate code formating. Thanks.

NickTux gravatar imageNickTux ( 2014-07-05 14:34:47 -0600 )edit

Thanks for the reply. Output of command line inserted above in the question.

SudoHalt gravatar imageSudoHalt ( 2014-07-06 06:42:30 -0600 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2014-07-06 06:55:16 -0600

NickTux gravatar image

1st solution

If it is not exist, create the directory /etc/X11/xorg.conf.d/

sudo mkdir /etc/X11/xorg.conf.d

Then, run the following command as one command (copy-paste from here)

echo -e ' Section "Device"\n\tIdentifier  "Intel Graphics"\n\tDriver      "intel"\n\tBusID       "PCI:0:2:0"\n\tOption      "Backlight"       "intel_backlight"\n EndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

Restart the X session or reboot and see if the problem fixed.

2nd solution

Try some parameters on kernel, via grub. You can do that if you edit the appropriate file.

sudo gedit /etc/default/grub

at the line which begins like this GRUB_CMDLINE_LINUX= carefully add the parameter acpi_osi= , thus the line will become something like this(do not change other parameters and leave a space between acpi_osi= and the next parameter)

GRUB_CMDLINE_LINUX="acpi_osi= vconsole.font=latarcyrheb-sun16 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 rd.lvm=0 rd.md=0 rd.dm=0"

proofread, save the document and update grub configuration with following command

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

After you reboot the system, the problem might be fixed, but (usually) you will lose the indicator.

edit flag offensive delete link more

Comments

Thank you so much! I tried the first solution which even worked with Opensuse.

SudoHalt gravatar imageSudoHalt ( 2014-07-09 03:24:59 -0600 )edit

@SudoHalt, if the answer helped you to solve the problem, please mark the answer as the correct one. Also, use your votes (they are for free) :)

Thanks

NickTux gravatar imageNickTux ( 2014-07-09 03:34:48 -0600 )edit

This one help me up with a similar problem running Fedora 20 on a Sony Vaio Laptop (VGN-NR220FE). The specific problem I had was that the brightness fn keys worked but in the range 90%-> 100% brightness (As you can imagine that was frustrating).

murpholinox peligro gravatar imagemurpholinox peligro ( 2014-07-11 23:21:17 -0600 )edit

Great! Worked on Fedora 20 with Lenovo Z360!

Capaça gravatar imageCapaça ( 2014-09-13 20:34:10 -0600 )edit

Worked for me Thank you

Adam Blansett gravatar imageAdam Blansett ( 2014-10-01 18:34:02 -0600 )edit
0

answered 2015-01-22 07:26:09 -0600

siva gravatar image

Hi all,

I just followed the first solution from above and restarted the fedira18 but, it stuck at some point and not getting home screen of fedora.

Please help.

edit flag offensive delete link more
0

answered 2015-07-14 01:30:01 -0600

This works good!

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf.

Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

and this works too! echo 1800 >> /sys/class/backlight/intel_backlight/brightness

depends on ur primary display adapter

edit flag offensive delete link more

Comments

this suggestion caused my machine to be unable to boot.

ReeseZee gravatar imageReeseZee ( 2016-12-08 10:58:06 -0600 )edit
0

answered 2015-12-14 06:36:40 -0600

Solution 1 is working for me with fedora20

edit flag offensive delete link more
0

answered 2015-08-25 22:46:24 -0600

aarons gravatar image

I tried several things before finding this post: How to control brightness in fedora?

sudo yum install xbacklight
xbacklight -set 90

This doesn't completely solve the issue, but it at least makes it possible to change the brightness. Nothing else worked for me. I'm running Fedora 21 with XFCE Desktop on a ZBook.

edit flag offensive delete link more

Comments

to get xbacklight to work on Asus ZenBook i915 HAswell Fedora24 I had to remove nomodeset from boot params

ReeseZee gravatar imageReeseZee ( 2016-12-08 11:22:32 -0600 )edit

Question Tools

Stats

Asked: 2014-07-05 13:22:27 -0600

Seen: 16,153 times

Last updated: Jan 22 '15