Ask Your Question
1

Fedora 20: ATI Radeon HD 4890 fan is running on 100% all the time

asked 2014-07-03 01:12:02 -0600

VoidByte gravatar image

updated 2014-09-05 10:51:38 -0600

mether gravatar image

Graphics: Card: Advanced Micro Devices [AMD/ATI] RV790 [Radeon HD 4890] Display Server: Fedora X.org 1.14.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x1200@60.00hz

As the title mentioned: The fan is running @100% usage without any 3D graphics running. Is there any way to stop that behavior? Found some tutorails for Fedora 15 an 16 where this problem was handled, but they dont work here on F20. Do someone know what to do?

edit retag flag offensive close merge delete

Comments

Maybe this is not a problem with the Card , but some service ? Next time run the command top and see what happened.

NickTux gravatar imageNickTux ( 2014-07-03 02:24:03 -0600 )edit

No that is a common issue with Fedora. The Problem is, that all the solutions on the web are for old Fedora Versions and seems not longer to be supported.

VoidByte gravatar imageVoidByte ( 2014-07-03 07:01:19 -0600 )edit

O.O it worked! BUT you cant do it as user, and not with sudo. Just if you go in a full "su"

But thank you, thats awesome! Now i can hear something on my headphones without the sound of a rolling truck from my graphic card :D

VoidByte gravatar imageVoidByte ( 2014-07-06 07:34:18 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-03 08:20:05 -0600

NickTux gravatar image

updated 2014-07-06 08:27:08 -0600

OK. First of all, you don't have support from AMD (closed source driver) as far as I know, correct ? So you will have to go with Open Source radeon. Open a terminal and login as root and try this command (as root) echo low > /sys/class/drm/card0/device/power_profile .

Permanent

You can add a custom script/.service file for this command to be executed at every boot(or reboot) of the system.

sudo gedit /etc/systemd/system/amd_low_profile.service

and add the following content

[Unit]
Description=Low Profile AMD
After=display-manager.service

[Service]
Type=oneshot
ExecStart=/usr/bin/echo "low" > /sys/class/drm/card0/device/power_profile

[Install]
WantedBy=multi-user.target

reload systemd with sudo systemctl daemon-reload

Then, enable the .service with

sudo systemctl enable amd_low_profile.service

Now it should be executed every time you reach the Desktop Environment.

You can check the results with

su - 
cat /sys/class/drm/card0/device/power_profile
edit flag offensive delete link more

Comments

thank you!

VoidByte gravatar imageVoidByte ( 2014-07-06 09:36:10 -0600 )edit
0

answered 2014-09-04 02:36:42 -0600

[Unit] Description=Low Profile AMD After=display-manager.service

[Service] Type=oneshot ExecStart=/usr/bin/bash -c '/usr/bin/echo "low" > /sys/class/drm/card0/device/power_profile'

[Install] WantedBy=multi-user.target

==========================================================================

works fine on fedora 20

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-07-03 01:12:02 -0600

Seen: 1,041 times

Last updated: Sep 04 '14