Ask Your Question
1

With seahorse-nautilus in Fedora 20, I can encrypt a file, but there's no obvious way to decrypt it

asked 2014-07-02 11:57:13 -0600

passthejoe gravatar image

updated 2014-07-02 13:23:35 -0600

mether gravatar image

I just installed seahorse-nautilus to encrypt files from the Nautilus file manager.

I can easily encrypt a file by right-clicking and choosing "encrypt."

But there is no "decrypt" option when I right-click on an encrypted file.

What am I missing in terms of packages and configuration?

edit retag flag offensive close merge delete

Comments

Got the same issue and I thought it was the same issue that someone reported to ubuntu http://askubuntu.com/questions/519977/seahorse-decrypt-context-menu-does-not-appear-in-nautilus (but it isn't)

lcestari gravatar imagelcestari ( 2014-10-29 06:38:42 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-02 15:31:33 -0600

NickTux gravatar image

updated 2014-07-02 15:37:48 -0600

Probably this is a bug , and it would be nice if you find the time to report it. I've found another-older bug about this same problem, but has not been resolved due to EOL version of Fedora.

https://bugzilla.redhat.com/show_bug.cgi?id=845855

As a workaround (this is a general script, not for decryption only - you can modify it or change it accordingly , if you want only the decryption feature)

you can use the Open with custom command script. Open a terminal and

gedit .local/share/nautilus/scripts/"Open with custom command"

Add the following content (copy-paste from here)

#!/bin/bash
var=$(zenity --entry \
--title="Add Application" \
--text="Use a custom command" \
--width="320")
if [ $? -eq 0 ] && [ "$var" ]; then
    $var "$1"
else
    exit 0
fi

save the file and then write in terminal

chmod 755 .local/share/nautilus/scripts/"Open with custom command"

Now, on right click, you should see an entry : scripts and there the Open with custom command. Click there and at the opened window write: /usr/bin/gpg . It should work without problems.

edit flag offensive delete link more

Comments

passthejoe gravatar imagepassthejoe ( 2014-07-07 12:40:48 -0600 )edit

@passthejoe very good. Thanks you participated on this. Until the bug addressed by the developers, you can use the workaround to do your job.

NickTux gravatar imageNickTux ( 2014-07-07 15:21:37 -0600 )edit

The workaround didn't work for me (the new entry is there but when I ask to run gpg it doesn't show or do anything

lcestari gravatar imagelcestari ( 2014-10-29 06:41:47 -0600 )edit

@Icestari , try gpg2 , /usr/bin/gpg2

NickTux gravatar imageNickTux ( 2014-10-29 18:02:49 -0600 )edit
0

answered 2015-09-27 12:28:28 -0600

I'm on F21. After installing seahorse-nautilus and restarting nautilus, the "Encrypt..." context menu item showed up and worked fine, but there was no "Decrypt" option in the context menu, nor in the File Properties "Open With" applications list.

Eventually I did the following, which seems to have fixed it:

gvfs-mime --set application/pgp-encrypted /usr/share/applications/seahorse-pgp-encrypted.desktop

After nautilus -q and re-starting nautilus, the context menu for an encrypted file offers "Open with Decrypt File" (and it works).

Here's the output of rpm -q for various packages that may be relevant: nautilus-3.14.3-1.fc21.i686 seahorse-nautilus-3.11.92-3.fc21.i686 gvfs-1.22.4-2.fc21.i686

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-07-02 11:57:13 -0600

Seen: 2,250 times

Last updated: Jul 02 '14