Ask Your Question
0

Set Wine's defualt backend to ALSA?

asked 2014-06-24 13:14:13 -0600

mezmerizedmonkey gravatar image

updated 2014-06-24 21:51:56 -0600

Hi, First post...

Running:
Kernel: 3.14.8-200.fc20.x86_64
Distro: Fedora 20 (Heisenbug) Wine: wine-1.7.19
All update repo alsa-wine packages installed...

For the lack of a better configuration tool...(jk Wine is great :)
Currenly pulseaudio is my default and does work, but how do I change it to ALSA for some better performance?

/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/Update-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/-/

Found a working solution from an older Wine wiki post: http://wine-wiki.org/index.php/Sound_Troubleshooting#Wine_and_MIDI_with_ALSA

  1. Open Wine Regedit to HKCU/Software/Wine/Drivers (a winepulse subkey should be hanging around there)
  2. In the Drivers key, add a new string called audio and make it's value alsa
  3. Reboot Wine
  4. Go to Wine configuration->Audio and, if everything worked, test things out (select your preffered devices)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-27 08:57:30 -0600

mether gravatar image

While I am glad you found the solution, you might want to stick to the defaults unless there really is a performance issue at play here

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-24 13:14:13 -0600

Seen: 1,818 times

Last updated: Jun 27 '14