Ask Your Question
3

How does a user install many True Type (.ttf) fonts at once in Fedora 20?

asked 2014-06-23 16:33:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I regularly need many more fonts than are available pre-pachaged for Fedora, and need to use specific commercial fonts for certain graphics projects. I have directories of fonts that I have purchased, and directories of freely available fonts from the Google fonts project, that I need to use in Fedora.

The only way I can discover to install a font in modern Gnome, is to go through each .ttf file one-by-one, clicking on the file, and then, once the font is shown in the previewer, click on install.

I don't want to have to click on each file, and then click install in the font preview application. I want to simply load all fonts in a directory, or drag and drop. It seems that I should be able to select the fonts, right click, and then select something like "Install fonts". Another logical option would be to select more than one font at a time, launch them in the font viewer, and then install all at once.

Since the ways that I assume would work to install multiple fonts don't work, does anyone know the correct way?

edit retag flag offensive close merge delete

7 Answers

Sort by » oldest newest most voted
4

answered 2014-06-24 22:34:57 -0500

Schlaegel gravatar image

Combining the information and related experience from the three current answers (ancatibor, deusdara, and NikTh)...

Installing fonts in stock Fedora 20 requires the command line, or at least the use of the files file access tool. I install fonts per user, because the permissions are easier to manage, and my history with Fedora upgrades has trained me to consider any file that doesn't live in /home/ as transient. To install fonts for the current user, copy or link the font files into either ~/.fonts or ~/.local/share/fonts. It is odd that both directories work, but they do.

Here is how I did it:

I opened terminal, and then used cd to get to the directory that contained my fonts. Once there, I ran the following command to find all of the fonts, and make a link to them in the ~/.fonts directory.

find . -iname '*.ttf' -exec ln -srvf {} ~/.fonts/ \;

I keep my downloaded fonts in a directory that isn't hidden, so that I can easily download additional fonts, organize existing fonts, and see all of the fonts and related licences. Because I didn't want to waste space with a separate copy of each font, I chose to make a link instead of copying each font. Also using links keeps the two directories in better sync.

I never ran fc-cache as mentioned in some of the answers. I didn't even logout. The fonts just started working immediately.

I sure wish that this were handled better by the GUI or at least clearly documented.

edit flag offensive delete link more

Comments

1

You can install fonts just fine using the gnome-font-viewer tool. Here's a post detailing how it's to be done on Ubuntu. It should also apply to Fedora - http://iloveubuntu.net/gnome-font-viewer-351-adds-gnome-branding-and-new-style-quantal-quetzal

Unfortunately, it does not handle mass font installation, which actually only requires copying your files as you've detailed above. You needn't make links - you can place the actual files there using nautilus.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-06-26 23:33:17 -0500 )edit
2

answered 2014-06-23 18:18:58 -0500

ancatibor gravatar image

You can install .ttf fonts globally (for all users), or locally (only for the current user, in this case you). Global font installation requires root privileges. Here I only explain the local install. To have your fonts all installed for your user account, you simply have to copy your fonts into "~/.local/share/fonts" directory. "~" is you home directory. Since the directory ".local" is hidden, you need to make it visible in Nautilus.

edit flag offensive delete link more
0

answered 2014-06-23 18:04:30 -0500

deusdara gravatar image

Hi

The easiest way to install truetype fonfs is:

Put your fonts in certain directory. The /home partition is the best place.

Make a link in the /usr/share/fonts/ that point to that directory.

Logout and relogin to the GUI

edit flag offensive delete link more
0

answered 2015-04-11 13:06:47 -0500

Mike B. gravatar image

The same answer in more user-friendly form: https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more
0

answered 2014-06-23 22:20:38 -0500

NickTux gravatar image

updated 2014-06-23 22:38:09 -0500

Here is a very detailed answer and you can choose the manual installation to install and use multiple fonts (.ttf files) at once.

Quoting here from the Original Answer:

Manual installation

User specific installation

Login as the user for which you want to install the font. Then open the .fonts directory - create one if it doesn't exists. Remember, it will be on your home directory and will be hidden by default. You can show or hide hidden directories in nautilus with Ctrl+H. Copy the font files to this .fonts directory. Now, open a terminal and type the following command to make the users’ accounts aware of the fonts.

  fc-cache -v

System wide installation

The system wide fonts are installed in the directory /usr/share/fonts. Create a directory there to hold your font collection, and copy the fonts to that newly created directory. Then run fc-cache -v to make the system aware of the newly installed fonts. You need root permission to make changes in /usr/share/fonts. You can use sudo or su - for that

### using sudo ###
sudo nautilus /usr/share/fonts
### this will open nautilus as root. create directory and copy fonts.

then

sudo fc-cache -v
### using su - ###
su -
nautilus /usr/share/fonts
### this will open nautilus as root. create directory and copy fonts.

then

fc-cache -v

fc-cache scans the font directories on the system and builds font information cache files for applications using fontconfig for their font handling. To force the re-generation of apparently up-to-date cache files, overriding the timestamp checking, you can issue the -f flag.

fc-cache -f -v
edit flag offensive delete link more

Comments

I just did a search on .ttf, and this seems to be the only question about this. If there's another, it's old enough that it's not on the first page.

sideburns gravatar imagesideburns ( 2014-06-23 22:26:32 -0500 )edit

OK then, I edited my answer to add as quote the part that helps. As this is a slightly different question (about multiple fonts installation at once and also for a newer version of Fedora) I have removed the P.S: This question could be closed as duplicate (I guess) too.

NickTux gravatar imageNickTux ( 2014-06-23 22:40:57 -0500 )edit

Thank you for the ideas. Though I am not afraid of the command line, I'm a bit surprised that almost all of the solutions so far require the use of the command line (usually to at least run fc-cache).

Is fc-cache automatically run at login? If it is, then should a logout followed by a login also work to make the fonts recognized (as suggested by deusdara).

Schlaegel gravatar imageSchlaegel ( 2014-06-24 00:09:30 -0500 )edit

Yes, you can avoid fc-cache if you want. I'm not quite sure if it runs in every login or every reboot, so you can try both.

NickTux gravatar imageNickTux ( 2014-06-24 01:00:41 -0500 )edit
0

answered 2015-06-10 17:50:29 -0500

Dies gravatar image

Font Manager allows you to install fonts for your user by drag and drop, files, folders, archives... But it does not allow installation/removal for system fonts, not yet anyway.

See http://fontmanager.github.io/

For Fedora packages built from the latest release (the version in Fedora's repositories is horribly outdated) see https://copr.fedoraproject.org/coprs/...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-23 16:33:09 -0500

Seen: 14,903 times

Last updated: Apr 11 '15