Ask Your Question
3

Disable entering root password everytime while mounting on Fedora 20

asked 2014-06-23 09:42:52 -0600

gowthamgts gravatar image

updated 2014-06-26 23:43:11 -0600

FranciscoD_ gravatar image

How do I disable entering root password everytime on mounting NTFS partitions in Fedora 20? I searched for the file org.freedesktop.udisks.policy but I cannot find one.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2014-06-23 12:15:45 -0600

NickTux gravatar image

updated 2015-07-18 16:12:14 -0600

You can do this, by adding your own rule (.pkla) file with appropriate content at the appropriate location.

sudo gedit /etc/polkit-1/localauthority/50-local.d/10-mount-without-password.pkla

it will open an empty file. Add the following content inside and replace USERNAME with the actual user name of yours.

[storage group mount override]
Identity=unix-user:USERNAME
Action=org.freedesktop.udisks2.filesystem-mount;org.freedesktop.udisks2.filesystem-mount-system
ResultAny=yes
ResultInactive=yes
ResultActive=yes

Save the document, and it should work instantly (without the need of logout or reboot or anything).

For Fedora 22

Open a terminal as root (or connect as root) and execute the following commands one by one (you can copy-paste from here).

cp /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy.bak

then

sed -i 's/auth_admin_keep/yes/g' /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy

If you encounter any problems during editing/changing this file, try to set selinux in permissive mode, then reboot and try again with the commands.

sed -i 's/enforcing/permissive' /etc/sysconfig/selinux
edit flag offensive delete link more

Comments

If you set it up to automount using gnome disks, you don't need to enter the password again and again. Gnome handles it via polkit IIRC. I haven't tested NTFS partitions in a while, though.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-06-26 23:42:57 -0600 )edit

Fantastic. Not the sort of thing a person could ever figure out themselves, and a constant frustration in Fedora. Thank-you, NikTh.

Steve HHH gravatar imageSteve HHH ( 2015-05-29 00:03:42 -0600 )edit

Nice, works also on Fedora 24.

freetomik gravatar imagefreetomik ( 2016-09-22 08:02:15 -0600 )edit
0

answered 2015-10-05 11:51:08 -0600

sed -i 's/enforcing/permissive' /etc/sysconfig/selinuxsed: -e expression #1, char 22: unterminated `s' command

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-23 09:42:52 -0600

Seen: 4,473 times

Last updated: Jul 18 '15