Ask Your Question

fonts in terminal

asked 2014-06-18 02:34:18 -0600

BPiek gravatar image

updated 2014-10-01 11:55:49 -0600

mether gravatar image

for nearly every font i've got bad spacing for letters like for example l. example

Why it looks like this? How can I get normal look?

edit retag flag offensive close merge delete


You write nearly - are there any specific fonts where you don't have the problem? And what happens if you create a new user and launch a fresh terminal there, does the problem persist?

liquidat gravatar imageliquidat ( 2014-06-18 10:36:32 -0600 )edit

I always install Infinality Freetype patches, that significantly improve font rendering

Nikos Roussos gravatar imageNikos Roussos ( 2014-06-19 04:20:13 -0600 )edit

DeJaVu Sans works good (only)

BPiek gravatar imageBPiek ( 2014-06-19 14:48:14 -0600 )edit

it says that i do have installed infinality-freetype-patches

BPiek gravatar imageBPiek ( 2014-06-19 15:00:06 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-06-18 10:46:21 -0600

NickTux gravatar image

updated 2014-06-18 12:07:55 -0600

I think that terminals (emulators..etc) have not good rendering support for such Fonts (regular fonts).

You must use the monospaced fonts if available. For example, try the DejaVu Sans and then try DejaVu Sans Mono to see the difference.

edit flag offensive delete link more

answered 2014-06-18 18:52:25 -0600

jargonaut gravatar image

I prefer to use Terminus font which is available in the main Fedora repo. It is the most crisp and clear font I've found. I usually set it to 11 point.

yum install terminus-fonts terminus-fonts-console
edit flag offensive delete link more


from terminus regular also hase that strange spacing problem (but italic works just fine, but I have to think to decide if it is better than DeJaVu)

BPiek gravatar imageBPiek ( 2014-06-19 14:53:50 -0600 )edit

Question Tools

1 follower


Asked: 2014-06-18 02:34:18 -0600

Seen: 1,108 times

Last updated: Jun 18 '14