Ask Your Question
0

Acer Aspire overheating/Bumblebee config?

asked 2014-06-10 14:19:24 -0500

feddol gravatar image

updated 2014-09-28 14:23:55 -0500

mether gravatar image

Hello,

I hope that someone can help me. My Acer Aspire 5742 laptop is overheating. Just some minutes after starting my system with Fedora 20 the laptop gets very warm and the fan is spinning loudly.

I've read a similar question on this site which suggestes to install BumbleBee. I've done that and also followed the additional introduction 'with the NVIDIA proprietary drivers'. The installation went well with a root account, my account seemed not to work with the terminal code.

I hope someone can help me fix that problem. I've linked the related thread above. I would be grateful if someone may change me config file to get the problem solved. Thanks in advance.

I'll paste my modified bumblebee.config below:

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia

## Client options. Will take effect on the next optirun executed.
[optirun]
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method
#             none - disable PM completely
# LINK REMOVED

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
Module=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib64/nvidia-bumblebee:/usr/lib/nvidia-bumblebee:/usr/lib64:/usr/lib
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib64/nvidia-bumblebee/xorg,/usr/lib64/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

Additional information (I'm speaking about testing Bumblebee with a demo found on the fedoraproject site /bumblebee: Pasting optirun glxgears -info | grep "GL_VENDOR" in the terminal displays

[  619.620044] [ERROR]The ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-13 01:44:21 -0500

TForsman gravatar image

updated 2014-06-13 08:58:50 -0500

I would suggest to make sure bumblebee is really installed correctly and running first. [ERROR]Could not connect to bumblebee daemon - is it running?

That tells us that it's not running at the moment. So go through these commands to make sure it's installed and running:

First install dependencies

yum install -y libbsd-devel libbsd glibc-devel libX11-devel help2man autoconf git tar glib2 glib2-devel kernel-devel kernel-headers automake gcc gtk2-devel

Then VirtualGL

yum install VirtualGL

Install bumblebee

yum -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee/fedora20/noarch/bumblebee-release-1.1-1.noarch.rpm

yum -y install bbswitch bumblebee

Get bumblebee with nvidia

yum -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee-nonfree/fedora20/noarch/bumblebee-nonfree-release-1.1-1.noarch.rpm

yum install glibc-devel

yum -y install bumblebee-nvidia

Reboot your system and test it again with:

optirun glxgears -info | grep "GL_VENDOR"

When I'm running these commands, I always gets optirun/bumblebee to work.

The guide for these commands are located here: http://fedoraproject.org/wiki/Bumblebee

I never need to edit/config the config files, should work out of the box when running these commands.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-06-10 14:19:24 -0500

Seen: 499 times

Last updated: Jun 13 '14