Ask Your Question
1

boot hangs, rngd read error

asked 2014-05-31 11:40:21 -0600

Ariovistus gravatar image

updated 2014-05-31 11:50:07 -0600

Edit: in an ongoing campaign to drive me crazy, my computer is booting fine now (I didn't DO anything!!) but my questions about rngd still stand.

So I have fedora on an old Latitude D620, and lately I've been experiencing ~5min hang on boot ('a start job is running for ...' firewalld/avahi/some others). It used to eventually get me to the graphical log in screen, but as of the last yum update, it seems to be hanging perpetually. Also, ctrl+alt+F2 doesn't give me a shell.

In journactl, I am seeing

systemd[1]: firewalld.service operation timed out. Terminating.
systemd[1]: Unit firewalld.service entered failed state.
systemd[1]: ModemManager.service operation timed out. Terminating.
systemd[1]: avahi-daemon.service operation timed out. Terminating.
systemd[1]: chronyd.service operation timed out. Terminating.
systemd[1]: Unit chronyd.service entered failed state.
rngd[525]: read error
rngd[525]: read error
...
rngd[525]: read error
rngd[525]: No entropy sources working, exiting rngd
systemd[1]: Unit avahi-daemon.service entered failed state.
systemd[1]: gdm.service operation timed out. Terminating.
systemd[1]: Unit gdm.service entered failed state.
systemd[1]: NetworkManager.service operation timed out. Terminating.

though to be fair, I'm seeing these on successful boots into older kernels (kernel-3.13.10 is working for me, anything newer hangs indefinitely).

What is rngd? is it supposed to be generating read errors like that? Is it causing those systemd timeouts?

edit retag flag offensive close merge delete

Comments

Do you really see all these "... timed out" and "... entered failed state" messages on every boot? None of these are normal and you should see system log (using journalctl) to see why they fail.

hedayat gravatar imagehedayat ( 2014-05-31 12:37:08 -0600 )edit

I was seeing them until she started booting properly again, but I didn't see anything in journalctl that indicated why they were.

Ariovistus gravatar imageAriovistus ( 2014-05-31 17:17:29 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-05-31 17:31:29 -0600

updated 2014-05-31 17:35:19 -0600

rngd gathers entropy from a hardware device, You don't have one, so rngd doesn't work. This is expected, and not related to your problem. You can do systemctl disable rngd with no ill effects to stop seeing the messages.

edit flag offensive delete link more

Comments

Why is rngd vendor preset is enabled even on devices that may not have the hardware random number generator? I am seeing a lot of these lines and system fails to boot.

sudhirkhanger gravatar imagesudhirkhanger ( 2016-01-02 09:14:02 -0600 )edit

There's a huge advantage to using it when the hardware supports it. The downside of having it enabled by default is the error messages on systems without the hardware. Only the error messages. It does not cause boot failures, that's something else.

randomuser gravatar imagerandomuser ( 2016-01-02 11:57:27 -0600 )edit

I find it strange that devs didn't bother to validate if hardware exist or not.

sudhirkhanger gravatar imagesudhirkhanger ( 2016-01-02 12:20:17 -0600 )edit

There is validation; the service fails to start when compatible hardware is not present. You could argue that the daemon should then disable the service that invokes it, I suppose, but the concept of a daemon mucking in service configs doesn't sound great to me.

randomuser gravatar imagerandomuser ( 2016-01-03 16:51:19 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-31 11:40:21 -0600

Seen: 3,574 times

Last updated: May 31 '14