Ask Your Question
0

fedora GRUB2 Configuration to enter new menu items.

asked 2014-05-27 03:24:37 -0600

SonaliVerma gravatar image

Wanting mmodificare the menu of the bootloader of Fedora 20 XFCE to make possible the restart and shutdown PC at startup instead of a distro on the PC itself, I modified the file / etc/grub.d/40_custom inserting rows

menuentry "Reboot the PC" { reboot }

menuentry "Halt" { halt }

so, after giving the command

grub2-mkconfig-o / boot/grub2/grub.cfg

restart the PC the boot loader menu has two new items: "Reboot the PC" and "Halt" selecting "Restart PC" actually the PC restarts, but selecting "Halt" the PC will not turn off ... appears on the screen the writing ACPI shutdown failed and the computer freezes so, without shutting down ... How do I put in the boot loader menu of Fedora 20? IS there a chance to turn off the computer or does any alternative options exist?

edit retag flag offensive close merge delete

Comments

The title of this question is misleading; you know how to add the menu item, it just doesn't work as expected. I suggest you edit to make the issue more clear.

randomuser gravatar imagerandomuser ( 2014-05-27 18:53:58 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-27 18:57:47 -0600

Try using halt --no-apm as suggested in http://www.gnu.org/software/grub/manual/grub.html#halt . If that doesn't work, the problem is probably a faulty ACPI implementation on your system, or a problem with GRUB itself - not a configuration issue. Check for relevant firmware updates, and then consider filing either a bug against GRUB or a support ticket with your hardware vendor.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-27 03:24:37 -0600

Seen: 297 times

Last updated: May 27 '14