Ask Your Question
0

Can not install Gnome on Fedora 20

asked 2014-05-24 09:15:30 -0600

Rong Nguyen gravatar image

updated 2014-05-24 13:51:08 -0600

mether gravatar image

Hi community, I'm using Fedora KDE 20, and i would like to install Gnome, but when i execute command yum install @gnome-desktop, it raise this error:

Error: Package: gstreamer1-plugins-bad-freeworld-1.2.1-1.fc20.x86_64 (rpmfusion-free)
           Requires: librtmp.so.0()(64bit)
           Available: librtmp-2.3-1.el6.rf.x86_64 (rpmforge)
               librtmp.so.0()(64bit)
           Available: librtmp-2.4-0.3.20110811gitc58cfb3e.fc19.x86_64 (rpmfusion-free)
               librtmp.so.0()(64bit)
           Installed: librtmp-2.4-1.20131205.gitdc76f0a.fc21.x86_64 (@rpmfusion-free-rawhide)
              ~librtmp.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Is there any ways to solve this issue?

Thank for any suggestions :-)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-05-24 23:31:31 -0600

updated 2014-05-24 23:34:22 -0600

There are a few things I'm concerned about here:

Available: librtmp-2.3-1.el6.rf.x86_64 (rpmforge)
               librtmp.so.0()(64bit)

You have a repository for el6 installed on your system. That's a different linux distribution, and you shouldn't be using those repositories on Fedora. Disable that with yum-config-manager --disable rpmforge.

       Available: librtmp-2.4-0.3.20110811gitc58cfb3e.fc19.x86_64 (rpmfusion-free)
           librtmp.so.0()(64bit)

You have a repository for Fedora 19 on your system. Fedora 19 is not Fedora 20. You should remove the RPMfusion repos, then go through the process to add them again to make sure the repository information is correct. yum remove rpmfusion*release then following the instructions at https://rpmfusion.org should do.

       Installed: librtmp-2.4-1.20131205.gitdc76f0a.fc21.x86_64 (@rpmfusion-free-rawhide)
          ~librtmp.so.1()(64bit)

You have a repository for Rawhide on your system. Rawhide is not Fedora 20. If the previous step does not remove the repo (check with yum repolist) you should disable and remove it as well.

After ensuring that the available repositories are intended to be used on Fedora 20, clean up with the command yum distrosync --releasever 20 followed by fixfiles onboot;reboot. If it isn't clear to you which repos might be incorrect, update your question with the output of yum repolist and the contents of the relevant questionable file in /etc/yum.repos.d/ .

Package installation should work as expected after you have corrected the repo misconfiguration and performed a distro-sync.

edit flag offensive delete link more

Comments

Thank man, i can not upvote because of my point, sorry :-)

Rong Nguyen gravatar imageRong Nguyen ( 2014-05-25 22:47:10 -0600 )edit

No worries, glad I could help.

randomuser gravatar imagerandomuser ( 2014-05-26 00:42:28 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-24 09:15:30 -0600

Seen: 252 times

Last updated: May 24 '14