Ask Your Question
1

How do I stop packagekit so I can install stuff?

asked 2014-05-17 04:56:24 -0500

G sus gravatar image

updated 2014-09-28 10:46:33 -0500

mether gravatar image

Fresh install of Fedora 20 to my desktop with gnome and want to add software like tweaktool, but stopped by PK running constantly. Loads of suggested command lines on the forums - pointless for the obvious reason.

  • Where do I find 'prefrences' to uncheck autoupdates?
  • tried to edit package script from '1' to '0' but it wont save.

I'm using the terminal for installs because the 'software centre' doesn't work - it's completely empty bar window outlines - not very helpfull at all.

Thanks - I like Fedora, but...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2014-05-17 10:21:07 -0500

skytux gravatar image

Type in terminal gpk-prefs and select Check for updates: Never.

Hope this helps,

Germán.

edit flag offensive delete link more

Comments

Thanks for the suggestion (and thanks for editing the frustration out of my question!) but terminal won't accept any commands as PK is running and has locked yum.... 'waiting to exit' etc.

Still yet to find where I can disable PK.

i read about gSoftware as a package manager/installer. Does this need to be installed?

Thanks for any help.

G sus gravatar imageG sus ( 2014-05-17 16:44:54 -0500 )edit

Thank you :) that's it sorted.. now to update everything!

G sus gravatar imageG sus ( 2014-05-19 02:13:26 -0500 )edit
1

answered 2014-05-17 22:05:12 -0500

abadrinath gravatar image

Hello G sus, you might want to just kill package kit with the process number (find using ping -efal|grep package). Then, do kill [PROCESS NO].

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-17 04:56:24 -0500

Seen: 422 times

Last updated: May 17 '14