Ask Your Question

telnet and ftp not working

asked 2014-05-15 23:00:52 -0500

suraj.sm11 gravatar image

updated 2014-05-16 08:38:06 -0500

mether gravatar image

hi have installed fedo20 and updated trough yum update and installed vsftpd and telnet-server packeg but i am unable to do both from other pc help me..

edit retag flag offensive close merge delete


Someone has to say it - is there a reason you are using FTP and telnet? Why not ssh and... anything else ?

randomuser gravatar imagerandomuser ( 2014-05-16 01:25:48 -0500 )edit


cma gravatar imagecma ( 2014-05-16 02:16:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-05-16 13:45:22 -0500

aeperezt gravatar image

Well you for security reason you should not use telnet you should be using ssh, but is you still want to used you should open the port 23, to test you telnet and sftp configurations and services are running you could try telnet localhost on the same machine same goes for ftp

sudo firewall-cmd --add-port 23/tcp

To use ftp you also need to open another port 21

sudo firewall-cmd --add-port 21/tcp

This changes are not permanent only for current user session.

And if you can you should use sftp and ssh instead of telnet and ftp.

edit flag offensive delete link more

answered 2014-05-16 22:53:21 -0500

sergiomb gravatar image

I got this problem in 90s at that time we already have to disable firewall to access telnet port. On Fedora 20 to disable firewall and give a quick test you can do :

systemctl stop firewalld

and to not start at boot:

systemctl  disable firewalld

check is start or not at boot time systemctl is-enabled firewalld

Note: I'm not saying to disable firewalld , because you will have less protection, but to do a quick test. if it work . And also you can configure firewalld to give permission to access FTP and telnet port.

edit flag offensive delete link more

Question Tools


Asked: 2014-05-15 23:00:52 -0500

Seen: 1,339 times

Last updated: May 16 '14