Ask Your Question
0

Can't boot dracut-initqueue[303] failed to create link

asked 2014-05-12 13:39:16 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi, I just wanted to change to boot order.

But now I'm not able to boot anymore. ERROR: dracut-initqueue[303] ln failed to create symbolic link /dev/resume already exists

I already tried to recreate the grub2.cfg but without any success.

Does recreating the initramfs will help? If yes, how to do it?


UPDATE:

Ok, If I wait long enough the system will boot into the dracut shell after I type:

ln -s /dev/mapper/vg1-root /dev/root
exit

The system is booting into run level 1.

I have than recreated one time the initramfs with:

mkinitrd -f -v /boot/initrd-$(uname -r).img $(uname -r)

and booted the system and one time with:

dracut -f

However, both time the system was not able too boot.

Error message:

/dev/fedora-lap/root /dev/fedora-lap/swap does not exist.

Thanks for your help!

Christian

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-12 16:09:42 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have fixed it my self :-) ! The problem was/is that grub2-mkconfig has created a grub.cfg with the wrong "volume group name"?.

linux   /vmlinuz-3.5.7-8.xeno.fc20.x86_64 root=/dev/mapper/vg1-root ro rd.lvm.lv=fedora-lap/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora-lap/root  rhgb quiet

instead of

linux   /vmlinuz-3.5.7-8.xeno.fc20.x86_64 root=/dev/mapper/vg1-root ro rd.lvm.lv=vg1/swap vconsole.font=latarcyrheb-sun16 rd.lvm.lv=vg1/root  rhgb quiet

"fedora-lap" was the name of the volume as I have installed fedora but I changed it to "vg1" a time ago.

So grub2 config tools still believe that my volume group is "fedora-lap", actually I have no idea how to change that. Can someone point me to the right direction on how to change that please.

Thanks in advance, Christian


UPDATE:

I found the (wrongdoer) file it is the default grub file

 /etc/default/grub

which was not updated as I have changed the volume group name! ^^

Thanks anyway! Have a nice evening/day... :-)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-05-12 13:39:16 -0600

Seen: 2,312 times

Last updated: May 12 '14