with NM_CONTROLLED=no who starts the interface? [closed]

asked 2014-05-11 06:44:12 -0600

graemev gravatar image

updated 2014-09-12 21:38:53 -0600

mether gravatar image

On the page http://docs.fedoraproject.org/en-US/Fedora/13/html/Virtualization_Guide/sect-Virtualization-Network_Configuration-Bridged_networking_with_libvirt.html and several other places.

It says:

Instead of turning off NetworkManager, add "NM_CONTROLLED=no" to the ifcfg-* scripts used in the examples.

(other pages just say add NM_CONTROLLED=no )

Having done this two scripts (ifcfg-em1 and ifcfg-br0)

May 11 09:19:53 real.home NetworkManager[1013]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-em1 May 11 09:19:53 real.home NetworkManager[1013]: ifcfg-rh: read connection 'em1' May 11 09:19:53 real.home NetworkManager[1013]: ifcfg-rh: Ignoring connection 'em1' / device '94:de:80:a4:ea:be' due to NM_CONTROLLED/BRIDGE/VLAN.

So Network-Manager ignores it Because I added NM_CONTROLLED=no ... historically I would have expected the "Normal Networking" to bring the interface up ... but I find I need to manually do:

service network start

I can't see anybody even attempting to to start these interfaces .

One thought I had is that this advice is old n=and now I should let Network-Manager start them?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by mether
close date 2014-05-11 13:38:40.113252

Comments

This is the latest version of this question, desired by the author https://ask.fedoraproject.org/en/question/46636/in-fedora-20-of-network-scripts-is-it-device-or-name/

marcindulak gravatar imagemarcindulak ( 2014-05-13 13:39:01 -0600 )edit

mether, Looks like you deleted my duplicate (thank you) this is the original question. I was hoping for an answer when I came back here. Right now I need to type "service netwrork start" after boot.

Historically I would have just looked at links to /etc/init.d/* but now that has changed as well ... sigh

I know in older systems, NetworkManager made a "pigs ear" of starting (normal) networking ... so I always just disabled it ... the init scripts did it right. I guess eventally NM has to work even for normal static/non-wifi networks ... I wonder if that time has come (and the above setup guide is wrong) ?

graemev gravatar imagegraemev ( 2014-05-23 13:41:56 -0600 )edit