Ask Your Question
0

Run fc20 but fc19 repos are used

asked 2014-05-07 01:17:30 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I upgraded with fedup to fc20 mainly successful. My machine runs a fc20 kernel and all installed fc20 packages. 'cat /etc/fedora-release' shows 'Fedora release 20 (Heisenbug)'.

But if I start apper or yumex both programs tell me that they use fc19 repos. All files in /etc/yum.repos.d/ use the variable $releasever . Where does fedora set this variable? Apparently /etc/fedora-release is ignored and the 19 is set somewhere else. Any help is welcome!

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2014-05-07 01:56:23 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Thanks for your hint but 'yum distro-sync' tries to downgrade all my fc20 packages to fc19. I didn't allow that.

edit flag offensive delete link more

Comments

You should've added a comment on my answer, not added a new answer...

QuLogic gravatar imageQuLogic ( 2014-05-07 03:36:22 -0600 )edit

Sorry for the new answer ...

In the meantime (after cleaning some old fc19 packages) I did

yum --releasever=20 distro-sync
rpm --rebuilddb
yum clean all

All these commands worked without errors. I can work with yum --releasever=20 update or yum --releasever=20 install but a call of yum without this option still calls fc19 repos (same for apper, yumex, ...)

Any ideas where the releasever=19 comes from? Should I reboot after the distro-sync?

KplMchl gravatar imageKplMchl ( 2014-05-07 06:35:17 -0600 )edit
0

answered 2014-05-07 11:21:16 -0600

sideburns gravatar image

Run this command as root:

package-cleanup --cleandupes

It's quite possible that you still have the rpm for the Fedora 19 release version, and yum checks for the rpm, rather than looking at the file itself.

edit flag offensive delete link more
0

answered 2014-05-07 01:29:06 -0600

QuLogic gravatar image

updated 2014-05-07 03:53:59 -0600

Did you follow the instructions for cleaning up?

  • sudo rpm --rebuilddb
  • sudo yum distro-sync --setopt=deltarpm=0
  • Possibly re-installing Chrome.

It appears you can do sudo yum --releasever=<release_number_you_want_to_sync_to> distro-sync, but I'm not sure how drastic that is.

edit flag offensive delete link more
0

answered 2014-05-07 08:20:35 -0600

Mike Heller gravatar image

I had the same problem with one of my machines.

I guess the problem was that the rpm "fedora-release-20-3.noarch" was not installed...

edit flag offensive delete link more

Comments

That was indeed the solution: fedora-release-20-3.noarch was installed but fedora-release-19-8.noarch still was installed as well. package-cleanup --cleandupes found this problem.

KplMchl gravatar imageKplMchl ( 2014-05-07 12:44:43 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-05-07 01:17:30 -0600

Seen: 379 times

Last updated: May 07 '14