Ask Your Question
0

Problems with booting (grub2)

asked 2014-05-05 09:03:38 -0500

gruni gravatar image

updated 2014-05-05 12:00:05 -0500

mether gravatar image

Hello,

as English is not my native language, please excuse any mistakes and as I am new to linux please try to help me in easy words, that'd be nice. :-)

On my computer I have an installed fedora 20 and windows 7. I use my windows private and fedora for work. Two weeks ago (before my vacation) I think I destroyed my grub2 installation. I am still able to boot into windows with the supergrub2disk, but this did not helped me at all yet, to get my files from the fedora partition. If I don't boot via disk, I just get

Minimal BASH-like line editing is supported [...]
grub>

So I tried to work after this scheme: http://fedoraproject.org/wiki/GRUB_2#Encountering_the_dreaded_GRUB_2_boot_prompt

My problem is, that I am not sure what to fill in at "5a. Declare your root partition:" and at the end of line "5b. Declare the kernel you wish to use. No matter what I use I just see the fedora boot-graphic for a second and then I get this error:

Warning: dracut: FATAL: No or empty root= argument
Warning: dracut: Refusing to continue

Generating "/run/initramfs/rdsosreport.txt"

Entering rescue mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save Generating "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

I would be very thankful for any help.

Best Regards
Gruni

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-05-05 09:32:16 -0500

updated 2014-05-05 09:32:48 -0500

grub> set root=(hd0,3) is a way to tell Grub the location of boot device.

hd0 tells that it is located on the first hard disk.

3 tells that the boot partition is on /dev/sda3.

edit flag offensive delete link more

Comments

Thanks for the answer. And how do I know what is my boot device? If I just type grub> ls / there is a boot/ and a root/ folder, but if I type in grub> set root=/ I will still get the above error message.

gruni gravatar imagegruni ( 2014-05-05 09:40:16 -0500 )edit
0

answered 2014-05-06 03:23:45 -0500

gruni gravatar image

Hi, I could resolve the problem now. I found a grub.cfg and could boot with the command configfile (hdX,Y)/boot/grub/grub.cfg. After that I could proceed with steps 6-8 from the dreaded boot promt manual.

Everything is working fine again now.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-05 09:03:38 -0500

Seen: 2,448 times

Last updated: May 06 '14