Ask Your Question
0

unable to play sound in fedora 20

asked 2014-04-17 06:18:49 -0600

DJ007 gravatar image

updated 2014-04-17 18:32:18 -0600

mether gravatar image

hi friends i am installing fedora 20 full version on my laptop and am also install all sound packages on my fedora. it play vedios but failed to play audio of that videos how can i recover this problem

edit retag flag offensive close merge delete

Comments

Do sounds work if playing audio files?

fidelleon gravatar imagefidelleon ( 2014-04-17 08:32:10 -0600 )edit

What's the codec of that video? and which players did you try?

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-17 09:45:40 -0600 )edit

no . no audio work for any file online file or my stored videos

DJ007 gravatar imageDJ007 ( 2014-04-17 09:47:00 -0600 )edit

i am trying vlc, Mplayer, and genome player

DJ007 gravatar imageDJ007 ( 2014-04-17 09:47:38 -0600 )edit

If you can't reproduce audio neither from videos nor regular adio files nor online sources (Youtube), it's very likely your audio card is not recognized correctly (or unrecognized at all). Could you post the output of the following command?

lspci | grep Audio

ran from a console window?

fidelleon gravatar imagefidelleon ( 2014-04-17 10:30:57 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-04-17 14:31:37 -0600

fidelleon gravatar image

Your kernel is recognizing your soundcard, and it's an Intel HDA codec, although they are made by many manufacturers.

First update your system to latest packages with yum update and reboot if needed.

In the Alsa Project homepage you have some troubleshooting steps:

First check, from a Terminal, if your volume settings are too low or zero. Open a terminal and execute alsamixer.

  • Checking all alsamixer tabs using the Tab key.
  • You can switching mute/unmute using the M key.
  • On the "Capture" tab, you can change the capture source setting using the spacebar.

If it doesn't help, you should check your computer technical manual in order to know which specific Intel codec you're using (you can post your model here and we'll check). The Windows driver filename might give you a clue.

Let's pretend it's an ALC880 (yours may/will be different, I'm using it as an example).

Check this page: http://git.alsa-project.org/?p=alsa-kernel.git;a=blob;f=Documentation/sound/alsa/HD-Audio-Models.txt;hb=HEAD

It seems intimidating but look for your model in such list:

Model name    Description
----------    -----------
ALC880
======
3stack        3-jack in back and a headphone out
3stack-digout 3-jack in back, a HP out and a SPDIF out
5stack        5-jack in back, 2-jack in front
5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
6stack        6-jack in back, 2-jack in front
6stack-digout 6-jack with a SPDIF out

If the description gives you a hint about your setup (for example you have a 3-jack in back, a HP out and a SPDIF out), it's very likely your model, in our case it's a 3stack-digout (again that's MY example).

Now you need to tell your system to use this specific model:

$ su - 
# echo options snd_hda_intel model=3stack-digout > /etc/modprobe.d/tweakaudio.conf

You just created a config file (tweakaudio.conf) which tells Linux to use your specific model, but you need to reboot.

Test your sound. If it doesn't still work, run alsamixer again, and if doesn't still sound, try with a different model from the model list (if you used a 3stack-digiout, use another model like 5stack-digout:

$ su - 
# echo options snd_hda_intel model=5stack-digout > /etc/modprobe.d/tweakaudio.conf

and reboot.

Repeat until you get sound OR you run out of possible models.

edit flag offensive delete link more
0

answered 2014-04-17 14:16:29 -0600

I have a similar problem. Fedora always defaults to the hdmi audio of my ATI graphics card which does in fact have no audi output jacks. I have to go to the audisetup in my system tray KMIX (KDE) every time I boot the system and change it to the motherboard audio. I have found no way to change that default yet.

edit flag offensive delete link more

Comments

This looks like a different issue than the original issue in this question. Anyway, try using pavucontrol to set the fallback device (on the "Output devices" tab), if it still doesn't work please start a new question.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-17 23:57:51 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-17 06:18:49 -0600

Seen: 398 times

Last updated: Apr 17 '14