Ask Your Question
6

Cannot play Vidoes in Fedora 20, No support for h264 decoder

asked 2014-04-11 22:37:41 -0600

ShayanH gravatar image

updated 2014-09-28 10:21:09 -0600

mether gravatar image

I have installed codes at rpmfusion completely. But VLC, SMPlayer and Totem can't play vidoes.

I have this error in VLC:

VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

SMPlayer log when I want play a video:

/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv, -nokeepaspect -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 41943081 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -noflip-hebrew -ass-styles /home/shayan/.config/smplayer/styles.ass -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -cache 2048 -osdlevel 0 -noslices -channels 2 -af equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/shayan/Videos/arsenal_1_2_dortmund.mp4

/usr/bin/mplayer: symbol lookup error: /lib64/libavcodec.so.55: undefined symbol: vpx_codec_vp9_dx_algo

I have Fedora 20 64 bit on my laptop ASUS K45.

edit retag flag offensive close merge delete

Comments

Try playing the file with smplayer, then open Options -> View Logs -> MPlayer and copy the text from there; either post it in your original post or to http://fpaste.org and post a link to it here.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-12 08:19:36 -0600 )edit

Added log file.

ShayanH gravatar imageShayanH ( 2014-04-12 12:07:09 -0600 )edit

As @mohanprakash said, you need to update your system to fix that "undefined symbol" error by installing the the latest libvpx package.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-13 10:24:20 -0600 )edit
1

try this brother

"yum install x264"

i think that is working for you

Tiger gravatar imageTiger ( 2014-08-01 15:17:08 -0600 )edit

12 Answers

Sort by » oldest newest most voted
7

answered 2014-08-05 03:23:43 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I recommend you to get the files in open and free coding formats like ogg.

But if you prefer to add the non-free plugins, you may do so. Inorder to add plugins for playing most non free formats, you must enable third party repo and the most common one we use with fedora is RPM fusion. To enable it open terminal and type following command.

su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

If it asks for password, please enter the super user (root) password.

Then type the following commands for installing the plugins/codecs.

sudo yum update

sudo yum install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg gstreamer1-libav gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-base-tools updates gstreamer1-plugins-good-extras gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-good gstreamer1-plugins-base gstreamer1 x264 vlc  smplayer

it and this should install most plugins and also VLC and SM player media players.

edit flag offensive delete link more
5

answered 2014-05-15 18:26:00 -0600

brendanlong gravatar image

If you have the right packages installed and it still doesn't work, try removing GStreamer registry so it will rebuild it:

rm -rf ~/.cache ~/.gstreamer*
edit flag offensive delete link more

Comments

Thanks, it helps for me.

malmed gravatar imagemalmed ( 2014-09-27 13:19:14 -0600 )edit
3

answered 2014-04-12 14:02:22 -0600

mohanprakash gravatar image

If you have installed Fedora 20 recently then you first update it

su -c'yum update'

then again install the codecs
Please refer to:this question

edit flag offensive delete link more
3

answered 2014-08-01 15:55:16 -0600

Tiger gravatar image

hello sir please try this

"sudo yum -y install x264"

edit flag offensive delete link more

Comments

Nice answer, and BTW, welcome to AskFedora!

abadrinath gravatar imageabadrinath ( 2014-08-01 21:32:25 -0600 )edit

thnkq sir :) but i am new in askfedora and i am not seen your message in askfedora can you tell me that how to see any comnet that are my own answer please help me...

Tiger gravatar imageTiger ( 2014-08-02 06:49:26 -0600 )edit

now i can se thnkq @hello

Tiger gravatar imageTiger ( 2014-08-02 06:49:51 -0600 )edit

Um, @Tiger, sorry for the late response. All posts go thru moderation ATM so someone has to approve of your comment. To know more, search 'Spam Mitigation' on AskFedora. Thanks.

abadrinath gravatar imageabadrinath ( 2014-08-05 20:52:48 -0600 )edit
1

answered 2014-09-28 23:30:10 -0600

SDas gravatar image

Easiest way to install installing codecs is first install fedy then install multimedia codecs from fedy. Here is the command to install fedy run it in terminal.

su -c "curl https://satya164.github.io/fedy/fedy-installer -o fedy-installer && chmod +x fedy-installer && ./fedy-installer"

edit flag offensive delete link more
0

answered 2014-04-11 23:54:47 -0600

anshprat gravatar image

Have you installed ffmpeg?

Does this help?

https://ask.fedoraproject.org/en/question/10061/how-can-i-configure-fedora-16-to-view-video-with-h264-coding-from-axis-camera/

What is the output of

rpm -q --all | grep "gstreamer" | sort

Is the video file you are trying to play proper (not corrupted)?

edit flag offensive delete link more

Comments

My video file is not corrupted and I can play it correctly on another OS.

Output of rpm -q --all | grep "gstreamer" | sort is:

PackageKit-gstreamer-plugin-0.8.13-1.fc20.x86_64

gstreamer-0.10.36-6.fc20.x86_64

gstreamer-ffmpeg-0.10.13-11.fc20.x86_64

gstreamer-plugin-crystalhd-3.10.0-6.fc20.x86_64

gstreamer-plugins-bad-0.10.23-5.fc20.x86_64

gstreamer-plugins-bad-free-0.10.23-20.fc20.x86_64

gstreamer-plugins-bad-nonfree-0.10.23-2.fc19.x86_64

gstreamer-plugins-base-0.10.36-6.fc20.x86_64

gstreamer-plugins-espeak-0.4.0-2.fc19.x86_64

gstreamer-plugins-good-0.10.31-10.fc20.x86_64

gstreamer-plugins-ugly-0.10.19-14.fc20.x86_64

gstreamer-tools-0.10.36-6.fc20.x86_64

gstreamer1-1.2.1-1.fc20.x86_64

gstreamer1-libav-1.2.3-1.fc20.x86_64

gstreamer1-plugins-bad-free-1.2.3-1.fc20.x86_64

gstreamer1-plugins-bad-freeworld-1.2.3-1.fc20.x86_64

gstreamer1-plugins-base-1.2.1-1.fc20.x86_64

gstreamer1-plugins-good-1.2.3-2.fc20.x86_64

gstreamer1-plugins-ugly-1.2.3-1.fc20.x86_64

gstreamer1-vaapi-0.5.8-3.fc20.x86_64

libnice-gstreamer1-0.1.4-2.fc20.x86_64

ShayanH gravatar imageShayanH ( 2014-04-12 03:43:07 -0600 )edit

I'm pretty sure ffmpeg is depreciated now.

abadrinath gravatar imageabadrinath ( 2014-08-02 21:05:11 -0600 )edit
0

answered 2015-03-07 12:47:40 -0600

Just install h264enc package: "yum install h264enc"

edit flag offensive delete link more

Comments

As the name, h264enc, indicates this package isn't useful for playing video files, more to creating video files encoded using the H264 video codec.

Ahmad Samir gravatar imageAhmad Samir ( 2015-04-12 02:42:16 -0600 )edit
0

answered 2014-09-29 10:07:30 -0600

tony gravatar image

Even though i installed all the codecs , i couldn't play any videos because of the h264 decoder problem. It was then only i realized that i didn't properly update my system. So i tried a restart and update. Afterwards, vlc works like a charm. Thanks to fedora forum.

edit flag offensive delete link more

Comments

edaman...thanks a lot friend! it worked for me! the updates for the libvpx.utils were needed and it worked! :)

i had same issues of h264 decoder!

Puffy gravatar imagePuffy ( 2014-10-10 01:35:23 -0600 )edit
0

answered 2014-08-24 18:47:35 -0600

biga gravatar image

yum install lame-libs

edit flag offensive delete link more
0

answered 2014-10-10 06:15:44 -0600

Vahid gravatar image

sudo yum -y install libvpx

It needs chroumium repository

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-04-11 22:37:41 -0600

Seen: 62,105 times

Last updated: Apr 07 '15