Ask Your Question
1

authenticate dialog rejects root password

asked 2014-04-07 16:06:15 -0600

phil707 gravatar image

updated 2014-09-29 17:50:27 -0600

mether gravatar image

The Gnome "authenticate" dialog rejects the root (=superuser) password. I finally updated from Fedora 14 to Fedora 20 a few days ago and I can successfully log in as "root" or use "su", but whenever I attempt something as a user that requires "authentication" under Gnome it rejects any entry I make. This seems to be the same problem reported by "calbaker" in question Problem with authentication dialogue, but the solution of reinstalling Fedora 20 is a last resort I prefer not to suffer. Surely someone knows what the real problem is.

(I don't know how to add "not yet solved" to an existing report!)

edit retag flag offensive close merge delete

Comments

I have the same problem. I am running in VirtualBox. Man I wish there was a way to get rid of ALL authentications.

gyannea gravatar imagegyannea ( 2014-07-31 07:19:46 -0600 )edit

anyone know?

gyannea gravatar imagegyannea ( 2014-07-31 07:23:16 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-04-07 18:12:19 -0600

sideburns gravatar image

If your user is part of the wheel group, you need to use your own password, not root's. Next time you try this, see if the dialog is asking for you to authenticate as root, or as yourself. If it's asking for the root password, say so in a comment, not an answer, and we'll go from there.

edit flag offensive delete link more

Comments

I believe I am in the "wheel" group. (Did that come from checking the "adminstrator" box?) However, neither my user password nor the root password is accepted. (I had already tried that.) The authenticate dialog does show my name. (So I suppose it is asking me to authenticate as myself.)

phil707 gravatar imagephil707 ( 2014-04-07 22:14:25 -0600 )edit

Yes. If it's listing your username, it expects your password. You do understand, I hope, that all Linux passwords are case sensitive.

sideburns gravatar imagesideburns ( 2014-04-08 01:56:22 -0600 )edit

Yes, that came from checking the "administrator" box when you created your user account in installer (Anaconda).

Check the system journal; run this command as root in terminal:

journalctl -b -f

leave it running and try to authenticate, it should print info from polkit about what went wrong.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-08 02:38:10 -0600 )edit

My passwords include upper and lower case letters, numerals, and punctuation characters.

The "journalctl -b -f" command reports "polkitd[579]: Operator of unix-session 1: Failed to authenticate to gain authorization...hilk)". (My user name is "philk".) That is the only message from "polditd" and appears only after I click "Cancel" in frustration after it responds "Sorry, that didn't work. Please try again." to my password entered several times, sometimes followed by CR and sometimes followed by clicking the "authenticate" button.

phil707 gravatar imagephil707 ( 2014-04-08 12:26:49 -0600 )edit

As an experiment, I logged in as my wife (not an administrator), and tried to "authenticate". It displayed my name in the authenticate window and failed with either the root or my personal password. ???

phil707 gravatar imagephil707 ( 2014-04-08 12:33:10 -0600 )edit
0

answered 2014-05-31 14:43:54 -0600

phil707 gravatar image

As suggested by @sideburns, using a different desktop was the answer. Apparently, there is something incompatible between Gnome 3 and my out-of-date hardware which manifested itself in my being unable to "authenticate" using the Gnome popup dialog. Gnome, not Fedora 20, was also the primary problem with the poor responsiveness of my system. Both problems were fixed by switching to "Xfce Desktop".

edit flag offensive delete link more

Comments

As suggested by Sideburns? I don't find any comment with respect to desktops. What is Xfce Desktop? A completely different version of Linux?

gyannea gravatar imagegyannea ( 2014-07-31 07:21:56 -0600 )edit

No, Xfce is a different Desktop Environment that is much less of a resource hog than Gnome is. To find out what it is, go to http://www.xfce.org/ And no, I never suggested using it, or at least not in response to this question.

sideburns gravatar imagesideburns ( 2014-07-31 16:58:44 -0600 )edit
0

answered 2014-04-07 21:02:45 -0600

sergiomb gravatar image

hi, please try clean up system

yum distro-sync
yum groupupdate 'Minimal Install'

you might upgrade others groups too

yum grouplist

For example:

yum groupupdate "GNOME Desktop" \
    "Development Tools" "Sound and Video" \
    "Games and Entertainment" "Administration Tools" \
    "Office/Productivity" "System Tools"

List packages that don't belong to distro anymore

yum list extras

and delete packages from old distributions and aren't shipped anymore

install rpmconf and clean .rpmnew, .rpmsave and .rpmorig try use rpmnew if it is possible

references: https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum

edit flag offensive delete link more

Comments

I mentioned upgrading from Fedora 14 to Fedora 20, but what I actually did was disconnect the external hard drive containing all my personal data and backups of Firefox bookmarks, Evolution profile and mailboxes, and anything else I thought to preserve, then I deleted all partitions on the Linux hard drive, and installed Fedora 20 from Live Update to that, now empty, drive. There can't be anything to clean up!

phil707 gravatar imagephil707 ( 2014-04-07 22:20:47 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-07 16:06:15 -0600

Seen: 3,805 times

Last updated: May 31 '14