Ask Your Question
0

Fedora 20 on Dell xps 15z screen resolution problem

asked 2014-03-31 09:20:33 -0500

la_fRA89 gravatar image

updated 2014-04-01 14:14:09 -0500

mether gravatar image

Hi to all, i've recently installed fedora 20 on my dell xps 15z (i'm newbie =)). Everyting works well except screen resolution. I can't set native screen resultion (1920x1080). The only possible options are: 1204x1024 or 1024x768. Anyone can help me?

Thanks in advance and sorry for my english

edit retag flag offensive close merge delete

Comments

The X server log should provide more insight into the issue; you can upload it to http://fpaste.org using this command in terminal as user:

fpaste /var/log/Xorg.0.log

and post a link to it here.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-31 11:01:17 -0500 )edit

Thank you, this is the X server log: http://paste.fedoraproject.org/90329/62865451

la_fRA89 gravatar imagela_fRA89 ( 2014-03-31 12:30:28 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-04-01 06:52:58 -0500

Ahmad Samir gravatar image

From the log I see the kernel command line includes the nomodeset and nouveau.modeset=0 rd.driver.blacklist=nouveau boot options and you only have one gfx chip, an Intel. Two points with this 1) the intel driver needs KMS (kernel mode setting) to work and nomodeset disables KMS and 2) if you don't have an nvidia gfx card the nouveau bits in the kernel cmdline are redundant.

Check the GRUB_CMDLINE_LINUX line in /etc/default/grub, make sure it doesn't include those boot options then generate a new grub.cfg, as root in terminal:

grub2-mkconfig -o /boot/grub2/grub.cfg

if it's a UEFI system:

grub2-mkconfig -o /boot/efi/EFI/Fedora/grub.cfg

Note that you can edit /boot/grub2/grub.cfg (if you have a UEFI system it's /boot/efi/EFI/Fedora/grub.cfg) as root and remove the boot options mentioned above manually, but you should also check /etc/default/grub so that subsequent execution of grub2-mkconfig won't screw up the kernel cmdline again.

With KMS not disabled the intel driver should work as expected.

edit flag offensive delete link more

Comments

I've only nomodeset option in my configuration, but if i remove it fedora doesen't load (empty black screen instead of user login)

la_fRA89 gravatar imagela_fRA89 ( 2014-04-01 09:10:29 -0500 )edit

Please remove nomodeset, boot the machine and when it finishes booting switch to a virtual terminal (by pressing Alt+Ctrl+F[2-6]) and upload /var/log/Xorg.0.log to fpaste.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-01 09:49:14 -0500 )edit

I've solved the problem removing nomodeset option and adding acpi_osi=linux noapic nolapic (as in this link). Now everything works well! Thank you!

la_fRA89 gravatar imagela_fRA89 ( 2014-04-01 11:31:02 -0500 )edit

Glad you got it fixed.

What's interesting is that there's nothing at all in Xorg.0.log about the second nvidia chip, I never had hardware with Optimus technology but I think it would show as a second gfx chip.

If your laptop has Optimus could you post the output of lspci -nn? (I am just curious).

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-02 01:41:26 -0500 )edit

Yes my laptop as optimus, this is the output:

00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port [8086:0101] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09)
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series ...
(more)
la_fRA89 gravatar imagela_fRA89 ( 2014-04-02 02:34:39 -0500 )edit
0

answered 2014-04-01 04:14:21 -0500

You are using the VESA driver which doesn't support high resolutions like the one you want. You need to:

  1. Install your graphic card driver
  2. Load the module for it
  3. Have X configured with it

This will give you the resolution you want.

To find out the model of your grpahic card type this on a console:

sudo lspci | grep VGA

edit flag offensive delete link more
0

answered 2014-03-31 15:59:20 -0500

sergiomb gravatar image

updated 2014-03-31 16:00:43 -0500

[    27.614] (EE) Screen 0 deleted because of no matching config section.

I got:

[    54.239] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    54.239] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    54.239] (==) intel(0): RGB weight 888
[    54.240] (==) intel(0): Default visual is TrueColor
[    54.240] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[    54.240] (**) intel(0): Relaxed fencing enabled
[    54.240] (**) intel(0): Wait on SwapBuffers? enabled
[    54.240] (**) intel(0): Triple buffering? enabled

you got :

[    27.614] (II) VESA(0): initializing int10
[    27.615] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    27.615] (II) VESA(0): VESA BIOS detected
[    27.615] (II) VESA(0): VESA VBE Version 3.0
[    27.615] (II) VESA(0): VESA VBE Total Mem: 65472 kB
[    27.615] (II) VESA(0): VESA VBE OEM: Intel(R)Sandybridge Mobile Graphics Chipset Accelerated VGA BIOS
[    27.615] (II) VESA(0): VESA VBE OEM Software Rev: 1.0
[    27.615] (II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
[    27.615] (II) VESA(0): VESA VBE OEM Product: Intel(R)Sandybridge Mobile Graphics Controller
[    27.615] (II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
[    27.620] (II) VESA(0): Creating default Display subsection in Screen section

So you are using Vesa drv not Intel drive , but why ? have you configuration in /etc/X11/xorg.conf.d/ or /etc/X11/xorg.conf ?

edit flag offensive delete link more

Comments

I have my configuration in /etc/X11/xorg.conf.d/, but i have only one conf file about the keyboard.

la_fRA89 gravatar imagela_fRA89 ( 2014-04-01 02:38:33 -0500 )edit

So can confirm that you don't have /etc/X11/xorg.conf (which is the correct) ? so is weird, look for Sandybridge on bugzilla , google etc

sergiomb gravatar imagesergiomb ( 2014-04-02 12:04:31 -0500 )edit

yes, i can confirm that i don't have xorg.conf in /etc/X11. Thanks, i will try to find a solution!

la_fRA89 gravatar imagela_fRA89 ( 2014-04-03 09:14:53 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-31 09:20:33 -0500

Seen: 1,715 times

Last updated: Apr 01 '14