Ask Your Question
0

Resolution stuck at 640x480 after failed nvidia driver install

asked 2014-03-30 12:44:42 -0600

Testat gravatar image

updated 2014-03-31 14:50:16 -0600

Hello there! I tried to install the binary nvidia driver by installing kernel-devel and akmod from RPMFusion. After a reboot X didnt start up. This is the log file:

[     3.573] 
X.Org X Server 1.14.4
Release Date: 2013-10-31
[     3.573] X Protocol Version 11, Revision 0
[     3.573] Build Operating System:  3.12.8-300.fc20.x86_64 
[     3.573] Current Operating System: Linux localhost.localdomain 3.13.7-200.fc20.x86_64 #1 SMP Mon Mar 24 22:01:49 UTC 2014 x86_64
[     3.573] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.7-200.fc20.x86_64 root=UUID=0193943e-fb2c-4952-bf30-3f0b1deac3d9 ro vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
[     3.573] Build Date: 28 February 2014  03:35:50AM
[     3.573] Build ID: xorg-x11-server 1.14.4-7.fc20 
[     3.573] Current version of pixman: 0.30.0
[     3.573]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[     3.573] Markers: (--) probed, () from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     3.573] (==) Log file: "/var/log/Xorg.5.log", Time: Sun Mar 30 19:16:21 2014
[     3.573] (==) Using config file: "/etc/X11/xorg.conf"
[     3.573] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     3.573] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     3.573] (==) No Layout section.  Using the first Screen section.
[     3.573] (==) No screen section available. Using defaults.
[     3.573] () |-->Screen "Default Screen Section" (0)
[     3.573] () |   |-->Monitor "<default monitor="">"
[     3.573] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[     3.573] (</default>) |   |-->Device "Videocard0"
[     3.573] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[     3.573] (==) Automatically adding devices
[     3.573] (==) Automatically enabling devices
[     3.573] (==) Automatically adding GPU devices
[     3.573] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[     3.573] (*) ModulePath set to "/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[     3.573] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[     3.573] (II) Loader magic: 0x80dd00
[     3.573] (II) Module ABI versions:
[     3.573]    X.Org ANSI C Emulation: 0.4
[     3.573]    X.Org Video Driver: 14.1
[     3.573]    X.Org XInput driver : 19.2
[     3.573]    X.Org Server Extension : 7.0
[     3.574] (--) PCI:(0:1:0:0) 10de:1187:3842:2760 rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     3.574] Initializing built-in extension Generic Event Extension
[     3.574] Initializing built-in extension SHAPE
[     3.574] Initializing built-in extension MIT-SHM
[     3.574] Initializing built-in extension XInputExtension
[     3.574] Initializing built-in extension XTEST
[     3.574] Initializing built-in extension BIG-REQUESTS
[     3.574] Initializing built-in extension SYNC
[     3.574] Initializing built-in extension XKEYBOARD
[     3.574] Initializing built-in extension XC-MISC
[     3.574] Initializing built-in extension XINERAMA ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-31 03:42:48 -0600

Ahmad Samir gravatar image

From the log it's apparent that the kernel module couldn't be built for your currently running kernel:

[     3.585] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[     3.585] (EE) NVIDIA:     system's kernel log for additional error messages.

IIUC, if you're using Fedora you need the RPMFusion repos. (RPMForge is for RHEL and CentOS). Check the RPMFusion guide to install the nvidia driver.

Note that uninstalling the nvidia packages (the ones in the RPMFusion repos, I haven't used RpmForge so I don't know if it does the same or not) should have reverted the changes (the nouveau bits) in /boot/efi/EFI/fedora/grub.cfg and /etc/default/grub automatically.

If you try with the RPMFusion repos and it still can't compile the nvidia kernel module you may need to update the kernel (I know the nvidia 331.49 kernel module compiles with kernel-3.13.* series, it could be that it doesn't compile with older kernels).

edit flag offensive delete link more

Comments

I'm sorry, I actually did get them from RPMFusion, not RPMForge. I must have confused the two. I have Kernel 3.13.7-200.fc20.x86_64. This should work with the drivers? I tried uninstalling/reinstalling multiple times without change in effect.

I used yum erase xorg-x11-drv-nvidia* for uninstalling and it apparently did not revert the changes to grub.cfg.

Testat gravatar imageTestat ( 2014-03-31 14:49:55 -0600 )edit

xorg-x11-drv-nvidia should revert the changes to grub.cfg via its preuninstall script; the script could have failed to execute correctly for any number of reasons.

From the guide I linked before:

yum install akmod-nvidia "kernel-devel-uname-r == $(uname -r)"

then post the output of:

rpm -qa "*kernel*" "*nvidia*" | sort

and after you reboot with the nvidia driver, upload /var/log/Xorg.0.log to fpaste:

fpaste /var/log/Xorg.0.log

and post a link to it here.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-01 07:09:52 -0600 )edit

This is the output of rpm -qa:


abrt-addon-kerneloops-2.2.0-1.fc20.x86_64
akmod-nvidia-331.49-1.fc20.2.x86_64
kernel-3.11.10-301.fc20.x86_64
kernel-3.13.7-200.fc20.x86_64
kernel-devel-3.13.7-200.fc20.x86_64
kernel-headers-3.13.7-200.fc20.x86_64
kernel-modules-extra-3.11.10-301.fc20.x86_64
kernel-modules-extra-3.13.7-200.fc20.x86_64
libreport-plugin-kerneloops-2.2.0-1.fc20.x86_64
xorg-x11-drv-nvidia-331.49-1.fc20.x86_64
xorg-x11-drv-nvidia-libs-331.49-1.fc20.x86_64

And this is xorg.0.log: http://paste.fedoraproject.org/90720/37979413/

Testat gravatar imageTestat ( 2014-04-01 14:24:05 -0600 )edit

When you installed akmod-nvidia did you get any errors?

What's the output of:

ls -l /usr/bin/Xorg
lsmod | grep nvidia

if the lsmod command doesn't give any output, post the output of:

modprobe nvidia
Ahmad Samir gravatar imageAhmad Samir ( 2014-04-02 02:12:51 -0600 )edit

ls -l /usr/bin/Xorg gives

-rwsr-xr-x. 1 root root 2235904 Feb 28 04:38 /usr/bin/Xorg

lsmod | grep nvidia doesn't return anything while modprobe nvidia says

modprobe: ERROR: could not insert 'nvidia': Required key not available
Testat gravatar imageTestat ( 2014-04-02 12:37:01 -0600 )edit
0

answered 2014-03-30 14:12:25 -0600

AnoniMouse gravatar image

updated 2014-03-30 14:22:57 -0600

Hi there, first off, the resolution problem is probably because u havent reactivated the free nvidia driver ("nouveau"). do 'sudo gedit /etc/modprobe.d/blacklist.conf' and delete the 'blacklist = nouveau' -entry. reboot and that should fix it

Further on: Do uve got a nvidia graphics card with optimus technology (built in intel gfxc + dedicated nvidia gfxc)? if yes, try to install the driver via bumblebee. if not try this tutorial: Tutorial

hope i could help

(*some typos cause im typin from my 4" phone :P *)

edit flag offensive delete link more

Comments

Thanks for the answer. However /etc/modprobe.d/blacklist.conf doesn't exist on my system. /etc/modprobe.d/ only contains one file, openfwwf.conf.

No, I don't have optimus. I have a desktop with a Geforce GTX 760.

Testat gravatar imageTestat ( 2014-03-30 15:25:45 -0600 )edit

Dont having optimus sorts out pretty much of the problems possible -Im glad to here u dont have this kinda crap :D

Looking through what uve posted,

[ 3.573] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.7-200.fc20.x86_64 root=UUID=0193943e-fb2c-4952-bf30-3f0b1deac3d9 ro vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

i see that nouveau is blacklisted. Pls link ur tut for further help for delting the blacklisting :D. Maybe this causes the problems, however check out the other answer (by sideburns) , too.

AnoniMouse gravatar imageAnoniMouse ( 2014-03-31 01:12:54 -0600 )edit

ah yes, and there is no need to do a '#' in front of ur tags -whe r not in twitter/fb :D in fact its better to remove it for better recongisation

AnoniMouse gravatar imageAnoniMouse ( 2014-03-31 01:14:34 -0600 )edit

Thank you, this gave me the right idea. I edited /boot/efi/EFI/fedora/grub.cfg to remove nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off and now nouveau is working again. However it explicitly states at the beginning of the file that it should not be edited manually. Could this cause problems in the future?

Testat gravatar imageTestat ( 2014-03-31 02:35:35 -0600 )edit

basically it could -but it doesnt has to :) pls post the link which tutorial u used, because somewhere u have blacklisted nouveau -the usual way u do it via the blacklist.conf, as i wrote earlier -but there may be other ways, too. so id be happy with a link of the tutorial :)

AnoniMouse gravatar imageAnoniMouse ( 2014-03-31 08:51:55 -0600 )edit
0

answered 2014-03-30 20:01:18 -0600

sideburns gravatar image

Check under Settings for NVIDIA X Server Settings and if you have it, run it. (If not, use yum to install nvidia-settings, then run it.) Click on X Server Display Configuration and make sure that it recognizes your monitor correctly, because if it doesn't, that might be the issue. If it does, look at Resolution on the right. It may currently say Auto, but in any case, check to see what resolutions are available, and if you know what the proper value is, select it. Make sure to save your changes to the X Configuration file before exiting. You may need to log out and back in (not reboot) before you see any changes, but this should get things back where they belong. If the proper value isn't listed, there may be other issues, but let's not worry about that until we have to.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-03-30 12:44:42 -0600

Seen: 2,658 times

Last updated: Mar 31 '14