Ask Your Question

a broken package [Requires: perl(VMS::Filespec)]

asked 2014-03-27 07:54:27 -0600

rohithzr gravatar image

updated 2014-09-30 11:15:28 -0600

mether gravatar image

when i am executing [yum update] it gives

Error: Package: perl-PathTools-3.2701-1.el5.rf.i386 (rpmforge)
           Requires: perl(VMS::Filespec)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

When i execute [rpm -Va --nofiles --nodigest], i get

/var/tmp/rpm-tmp.wrqr9U: line 851: IntegrateWithGNOME: command not found

I have already tried [yum reinstall perl and perl-PathTools seperately] and [yum erase perl-PathTools or perl] wil erase 699MB of dependent packages causing a lot of trouble

How can i fix this error without erasing perl?

edit retag flag offensive close merge delete


yum clean all

Loaded plugins: langpacks, refresh-packagekit
Cleaning repos: Dropbox adobe-linux elegance-colors fedora gtk-theme-config home_Kenzy_packages infinality infinality-noarch numix rpmforge
              : rpmfusion-free-rawhide rpmfusion-nonfree rpmfusion-nonfree-updates updates virtualbox
Cleaning up everything
rohithzr gravatar imagerohithzr ( 2014-03-27 07:59:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-03-27 10:59:07 -0600

marcindulak gravatar image

updated 2014-03-27 11:00:33 -0600

Assuming you are on Fedora (are you on Rawhide?) - you are trying to install a package from RHEL5 - disable the rpmforge repository:

 su -c "yum-config-manager --disable rpmforge"

In order to avoid problems - keep only the default Fedora repos. See and

edit flag offensive delete link more


i am using Fedora 20 GNome Installe through live media. i am not sure but i guess rpmforge was for running mp3 files and nvidia drivers.... will it be safe to disable rpmforge, will i sill be able to use mp3s and nvidia drivers and vmware (not sure if it nees rpm)

rohithzr gravatar imagerohithzr ( 2014-03-27 11:35:28 -0600 )edit

Please read the provided links. There is a confusion between rpmforge ( - it provides packages for RHEL) and rpmfusion (this is the one you want on Fedora for additional software) repositories. Disable rpmforge as given above.

marcindulak gravatar imagemarcindulak ( 2014-03-27 12:44:03 -0600 )edit

thanks read these links and now it's more cleared..... it is working correctly now :)

rohithzr gravatar imagerohithzr ( 2014-03-27 14:16:46 -0600 )edit

Question Tools


Asked: 2014-03-27 07:54:27 -0600

Seen: 2,202 times

Last updated: Mar 27 '14