Ask Your Question

easyLife not able to install anything

asked 2014-03-16 07:28:27 -0600

cyberjar09 gravatar image

updated 2014-03-16 09:41:51 -0600

I am trying to install some software using easylife but the installation fails everytime becuase too too many failed attempts to contact the server.

--2014-03-16 20:24:53-- Resolving ( . Connecting to (||:80.. . connected. HTTP request sent, awaiting response... No data received. Retrying.

I tried switching my DNS to use google dns but the DNS server of my ISP is not the issue.

Edit: my repolist $ yum repolist
Loaded plugins: langpacks, refresh-packagekit repo id -> repo name
churchyard-chromium-russianfedora/20/x86_64 -> Copr repo for chromium-russianfedora owned by churchyard
fedora/20/x86_64 -> Fedora 20 - x86_64
google-chrome -> google-chrome
google-talkplugin -> google-talkplugin
rpmfusion-free/20/x86_64 -> RPM Fusion for Fedora 20 - Free
rpmfusion-free-updates/20/x86_64 -> RPM Fusion for Fedora 20 - Free - Updates rpmfusion-nonfree/20/x86_64 -> RPM Fusion for Fedora 20 - Nonfree
rpmfusion-nonfree-updates/20/x86_64 -> RPM Fusion for Fedora 20 - Nonfree - Updates
updates/20/x86_64 -> Fedora 20 - x86_64 - Updates repolist: 53,836

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2014-03-16 14:27:29 -0600

duli gravatar image

I don't why you have scientific linux repositories enabled.

Anyway, easyLife was meant to be installed on a fresh Fedora box.

Please, download and install Fedora from the official website ( ).

Make sure easyLife is the first thing you install on your Fedora box. Don't forget to update your system.

After you run easyLife and install the things you want, you can safely remove easyLife.

edit flag offensive delete link more


@duli thanks for the response, this is a close to fresh install (1 week old) of Fedora 20 (Gnome3). I tried to grep for "scientific" in my /etc/yum.repos.d folder but there is nothing pointing there... baffling! dreading doing the whole install again sigh@Glenn

cyberjar09 gravatar imagecyberjar09 ( 2014-03-17 08:46:59 -0600 )edit

answered 2014-03-16 08:26:50 -0600

Glenn gravatar image

updated 2014-03-16 08:28:32 -0600

EasyLife was written for Fedora. I'm not so sure it will work properly under Scientific Linux. I'm assuming that you're using Scientific because of the repository errors you've provided.

If you are in fact using Fedora then disable the Scientific Linux repositories you're using and try EasyLife again.

edit flag offensive delete link more


@Glenn I am using Fedora 20, I did not add scientific linux repos to my list, not sure why it is even looking there. Ill google around on how to disable it.. Thanks.

cyberjar09 gravatar imagecyberjar09 ( 2014-03-16 09:20:24 -0600 )edit

You can manually edit the Scientific repos that reside in /etc/yum.repos.d. Change any instance of enabled=1 to enabled=0. Save and exit. The repos should be disabled.

Glenn gravatar imageGlenn ( 2014-03-16 10:22:29 -0600 )edit

Since you've posted your repolist I now have no idea why the Scientific repos are showing up.

Glenn gravatar imageGlenn ( 2014-03-16 10:34:02 -0600 )edit

answered 2014-03-16 08:03:42 -0600

deusdara gravatar image


Please Install those repositories.

To enable access to both the free and the nonfree RPMFusion repository use the following command:

su -c 'yum localinstall --nogpgcheck$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm'
edit flag offensive delete link more


Hi @deusdara thanks for the response, but can you please elaborate on why installing these repos will help?

cyberjar09 gravatar imagecyberjar09 ( 2014-03-16 08:06:15 -0600 )edit


Now I can see your yum repolist has RPMFusion repository.

As per your first message I saw only scientific repository.

deusdara gravatar imagedeusdara ( 2014-03-16 11:20:18 -0600 )edit

Question Tools

1 follower


Asked: 2014-03-16 07:28:27 -0600

Seen: 579 times

Last updated: Mar 16 '14