Ask Your Question
4

How to hide certain users from GDM logon list?

asked 2014-03-15 10:34:05 -0600

dkarlovi gravatar image

updated 2014-03-15 12:04:18 -0600

mether gravatar image

Is there a way to whitelist / blacklist certain users from showing up on my GDM list? I've tried plenty of solutions (like adding

[greeter]
Exclude=<user>

to /etc/gdm/custom.conf but that feature seems deprecated (as it does not work). Ideally, I'd like to whitelist users, but even blacklisting is acceptable.

edit retag flag offensive close merge delete

Comments

@mether - please do not convert my comments into answers

marcindulak gravatar imagemarcindulak ( 2014-03-15 12:25:08 -0600 )edit

@marcindulak the way I've read it, this would disable the list entirely which is not what I want to do here.

dkarlovi gravatar imagedkarlovi ( 2014-03-15 15:26:53 -0600 )edit

Apparently this is a known bug in Gnome 3's gdm: https://bugs.freedesktop.org/show_bug.cgi?id=56729

wquine gravatar imagewquine ( 2014-03-15 22:10:54 -0600 )edit

3 Answers

Sort by » oldest newest most voted
5

answered 2015-02-19 18:34:00 -0600

ssieb gravatar image

Go to /var/lib/AccountsService/users If the user has already logged in, then there should be a file with their user name. If not, then copy a different one to a file with their user name. Edit the file and change the SystemAccount= line to true. Restart gdm and that user won't show up in the list.

edit flag offensive delete link more

Comments

2

This answer is simple, and it worked.

darakus gravatar imagedarakus ( 2015-05-19 08:59:10 -0600 )edit

I can confirm it works perfectly, and it's easy. Thanks

fedoramonsecond gravatar imagefedoramonsecond ( 2016-11-02 08:43:19 -0600 )edit
0

answered 2016-07-14 11:30:46 -0600

lsatenstein gravatar image

cd /etc/gdn/gdm.schema does not exist At least not with Gnome 3.20 or as presented in Fedora 24

edit flag offensive delete link more

Comments

Yes, but editing that file was never a good idea. Use the method in my answer or possibly move the UID to be less than 1000.

ssieb gravatar imagessieb ( 2016-07-14 15:48:07 -0600 )edit

changed UID to 900 but unfortunately the user is still in GDM list

fedoramonsecond gravatar imagefedoramonsecond ( 2016-11-02 08:35:22 -0600 )edit

Maybe the boundary is still 500 for backwards compatibility. But the other method is better anyway.

ssieb gravatar imagessieb ( 2016-11-03 13:12:47 -0600 )edit
-1

answered 2015-02-20 00:26:29 -0600

Edit the file /etc/gdm/gdm.schema find the section that currently looks like this:

<schema> <key>greeter/Exclude</key> <signature>s</signature> <default>bin,root,daemon,adm,lp,sync,shutdown,halt,mail,news,uucp,operator,nobody,nobody4,noaccess,postgres,pvm,rpm,nfsnobody,pcap</default> </schema>

And to exclude a user called qmail for example add qmail to the default list so the section looks like this.

<schema> <key>greeter/Exclude</key> <signature>s</signature> <default>qmail, bin,root,daemon,adm,lp,sync,shutdown,halt,mail,news,uucp,operator,nobody,nobody4,noaccess,postgres,pvm,rpm,nfsnobody,pcap</default> </schema>

That will stop user qmail appearing in the gdm greeter. There used to be a nice GUI tool to do this but is has not been in Ubuntu for the last few releases.

The other alternative is to set the UID of the user to under 1000. Those are considered to be system accounts which are excluded in the GDM greeter too. I hope this will help you. For any writing help you can use this professional essay writing service for better support.

edit flag offensive delete link more

Comments

there's not such a file (F25)

fedoramonsecond gravatar imagefedoramonsecond ( 2016-11-02 08:34:36 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2014-03-15 10:34:05 -0600

Seen: 13,173 times

Last updated: Jul 14 '16