Ask Your Question
0

Fedora Update Problem

asked 2014-03-03 17:46:43 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi Bros!

I downloaded Fedora 20 and install it. after I install it, it has an update and I updated it, but when I restart it has 2 version for me to choose: 3.10(which I downloaded and install) and 3.13(which I updated). Could you please explain for me?

Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-03-03 21:49:45 -0600

skytux gravatar image

updated 2014-03-03 21:51:42 -0600

I don't see any problem here. The kernel was updated, so you have two options: the older one and the new one. Just let it boot from the new kernel and enjoy your Fedora 20!

edit flag offensive delete link more

Comments

Adding to the above, the default behaviour is that kernels are installed in parallel so the system keeps at least 3 installed kernels; this is so that if a new kernel doesn't boot/work for some reason you have 2 older, supposedly working, kernels to boot.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-04 00:49:54 -0600 )edit

but the updated version is worked well. how can I delete the the 2 oder ones? thanks!

toaicd gravatar imagetoaicd ( 2014-03-04 08:40:30 -0600 )edit

Why do you want to delete the older versions? It is wise to keep them installed, they don't take too much space in your boot partition and if in a given moment you can't boot anymore with the newer kernel, then you have the older versions that will enable you to boot your machine.

skytux gravatar imageskytux ( 2014-03-04 09:13:38 -0600 )edit
0

answered 2014-03-03 23:59:28 -0600

jensm gravatar image

As skytux said, click the new one and enjoy your F20 :)

edit flag offensive delete link more
0

answered 2014-03-08 02:46:11 -0600

lsatenstein gravatar image

Do not delete the previous version. Fedora keeps up to three versions, the two previous and one current. And as well, an emergency version.

The idea is that if you do something to cause a problem with the current version so that it does not start properly, you can click on a previous version and that version should work.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-03-03 17:46:43 -0600

Seen: 155 times

Last updated: Mar 08 '14