Ask Your Question
0

How to modify grub2 to boot updated linux kernel

asked 2014-02-10 09:49:01 -0600

Kristin Lu gravatar image

updated 2014-02-15 20:41:17 -0600

mether gravatar image

Hi,

(There is another thread of this, however, I did get my question answered).

This question is regarding how to build and boot Linux (upstream/updated) kernel on Fedora 20. (I am taking a class from UC extension, and this is the first assignment, so I don't need to commit anything to the Linux source, but have to able to have a Linux kernel compiled and bootable to continue my homework assignment).

I have done the following: 1) Install a Fedora 20 from installation DVD (full version, for x86_64 system) on my PC (which runs Windows 8.1)'s internal hard drive. While installing, I select most features from the package (so, gcc and other development tools come with it). Note: I also select to install the bootloader (which is grub2) on my PC. 2) (Non-root) Get a stable Linux source from kernel.org (Note: tried download source tarball and untar (use tar -xvf), and git) 3) Pretty much follow the step from https://fedoraproject.org/wiki/BuildingUpstreamKernel . Namely: a) copied the config file which used to boot Fedora 20 from /boot directory to my Linux source directory. Run "make oldconfig" and hit "N" to new features. b) execute "make" (as non-root) c) execute "make modules_install", "make install" as root. (note: there is no config file generated under /boot after make install - does not like the existing bootable Fedora 20 (which come with Linux 3.11.x), which I can find config file under boot for it) d) reboot.

I saw the following messages on the screen: error: /vmlinuz-3.13.2 has invalid signature error: you need to load the kernel first

I was not able to boot the newly built Linux kernel.

I saw other posting about the "invalid signature" and someone mentioned it's bootloader issue.

I think there are some steps missing between 3.c and 3.d ==> I looked the script executed after "make install" - it just modify System.map and copy to /boot directory, and tries to execute /etc/lilo (an older bootloader), I could not find the part dealing with grub2.

So basic question is: what should I do to make grub2 able to boot the new Linux kernel? (Note: I am able to select to boot either Windows or Linux 3.11.x (Linux kernel come with Fedora 20) from the boot menu).

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-16 10:44:04 -0600

Your computer has probably secureboot turned on, as this is required for Window 8+ certification. As such, it will only run kernels signed by a Microsoft signed key.

To boot a custom kernel, you will need to get into your UEFI setup, and disable secureboot.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-10 09:49:01 -0600

Seen: 1,318 times

Last updated: Feb 16 '14