Bumblebee - primusrun won't use discrete Nvidia card.

asked 2014-02-08 13:32:12 -0500

exodius gravatar image

updated 2014-02-09 05:53:11 -0500

Running Fedora 20, installed latest bumblebee with primus. Running optirun glxspheres gives reasonable FPS:

 [farid@fedora ~]$ optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce 610M/PCIe/SSE2
186.725936 frames/sec - 179.057475 Mpixels/sec
195.299852 frames/sec - 187.279278 Mpixels/sec
187.499554 frames/sec - 179.799322 Mpixels/sec

As output shows, optirun uses discrete GeForce card. Issuing primusrun glxspheres command gives following output:

[farid@fedora ~]$ primusrun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Indirect
OpenGL Renderer: Mesa DRI Intel(R) Sandybridge Mobile 
61.825519 frames/sec - 59.868253 Mpixels/sec
59.677798 frames/sec - 57.226950 Mpixels/sec
59.703602 frames/sec - 57.251694 Mpixels/sec

Also tried using following command, no change:

[farid@fedora ~]$ vblank_mode=0 optirun -b primus glxspheres 
Polygons in scene: 62464 
Visual ID of window: 0x21 
Context is Indirect OpenGL
Renderer: Mesa DRI Intel(R) Sandybridge Mobile 
62.312069 frames/sec - 59.395348 Mpixels/sec
59.680172 frames/sec - 57.229227 Mpixels/sec.

Thank you for any advice :)

edit retag flag offensive close merge delete

Comments

Not too sure. The wiki page here doesn't mention primusrun at all.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-02-09 02:24:48 -0500 )edit

Yes, wiki doesn't mention primusrun, but running optirun -b primus glxspheres doesn't use Nvidia card as well, you can find output difference in original post

exodius gravatar imageexodius ( 2014-02-09 05:51:21 -0500 )edit

hey, did you ever figured this out? I've been using primusrun without any problems until recently, now I have the same problem you do.

pablote gravatar imagepablote ( 2014-11-23 17:52:35 -0500 )edit

Hi, same here: Fedora 21 with bumblebee/nvidia installed.

PasqualeP gravatar imagePasqualeP ( 2014-12-11 05:17:16 -0500 )edit