Ask Your Question
2

ssh in fedora 20 fails with error "system is booting up"

asked 2014-01-29 12:56:21 -0600

aumicka gravatar image

updated 2014-01-29 18:48:39 -0600

FranciscoD_ gravatar image

After installing fedora 20 I am having problems using ssh remotely. when I ssh to my server I get the following msg: System is booting up. See pam_nologin(8)
Connection closed by xxx.xxx.xxx.xxx

I had no problems with fedora 18. I did not install fedora 19 so I can't comment on that.

edit retag flag offensive close merge delete

Comments

2

This bug has been already reported here → https://bugzilla.redhat.com/show_bug.cgi?id=1043212

Affects SSH, as has some various other side effects too.

I would suggest to keep tracking and also to participate in this bug report.

NickTux gravatar imageNickTux ( 2014-01-29 13:14:04 -0600 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2014-01-29 13:14:24 -0600

Marc lml gravatar image

updated 2014-01-29 13:15:03 -0600

Most likely this is because of /usr/lib/tmpfiles.d/systemd.conf:

F /run/nologin 0644 - - - "System is booting up. See pam_nologin(8)"

While /run/nologin exists, the system will only allow root to login, so login as root and either rm the file, or just reboot.

Source: http://archlinuxarm.org/forum/viewtopic.php?f=31&t=4079

edit flag offensive delete link more

Comments

It work for me. Thanks.

Wang Sen gravatar imageWang Sen ( 2016-12-13 21:43:35 -0600 )edit

Amazing stuff, it worked for me on Ubuntu when I installed systemd package and could not open new SSH connections

Dr.Shadow gravatar imageDr.Shadow ( 2017-01-05 16:58:04 -0600 )edit

Question Tools

Stats

Asked: 2014-01-29 12:56:21 -0600

Seen: 6,861 times

Last updated: Jan 29 '14