Ask Your Question
1

Black screen after suspend (sleep) under Fedora 20

asked 2014-01-27 18:20:58 -0600

gfreeman gravatar image

updated 2014-05-30 23:18:53 -0600

mether gravatar image

I have set up my laptop to always suspend ("sleep" in KDE) when the lid is closed. However, when I open the lid, everything is working except for the screen, which is black. I can interact with the machine using SSH or SFTP from another machine, and the keyboard seems to be alive, lighting up when I press keys, but I cannot see any output. The brightness level has been set to full. I have to hold down the power button to force it to close down and then restart it to regain the screen.

Under Fedora 19, the screen always came back properly when resuming, but the keyboard was sometimes dead,and I needed to close the lid and wait a while before trying again, and eventually it always worked properly.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-28 02:10:13 -0600

Gileade Oseiass gravatar image

May be driver problem, try upgrading.

edit flag offensive delete link more

Comments

Well I haven't installed any drivers explicitly and am not sure what I would need to do. I do a "yum update" every couple of days.

gfreeman gravatar imagegfreeman ( 2014-01-28 02:34:11 -0600 )edit

See if the problem you have is not this? https://bbs.archlinux.org/viewtopic.php?pid=1326670

Gileade Oseiass gravatar imageGileade Oseiass ( 2014-01-28 02:40:29 -0600 )edit

Thanks for your suggestion. I checked out that report but it is a different problem. I tried doing a sysctl suspend, and it suspended the machine as expected. Pressing the power button to resume brought back lights to the keyboard but the screen remained black, just as it does when I close and reopen the lid. Also, I never see the cursor on the black screen.

gfreeman gravatar imagegfreeman ( 2014-01-29 20:02:36 -0600 )edit
0

answered 2014-01-29 17:07:17 -0600

sergiomb gravatar image

you may try change vt , with ctrl + alt + F2 and back to X with ctrl + alt + F1 , may could refresh screen .

we need much more information what dmesg says after wake up, and /var/log/Xorg.0.log , to see what video card do you have . but better is open a bug report with all this information that I asked into Bugzilla , you may look here [1] and click on Report a new bug against this package in Fedora, or if you think is kde use [2] and maybe should also check xorg-x11-drv-(intel|ati|etc)

[1] https://admin.fedoraproject.org/pkgdb/acls/bugs/kernel

[2] https://admin.fedoraproject.org/pkgdb/acls/bugs/kde-runtime

edit flag offensive delete link more

Comments

1

Thanks very much for your advice. I have tried ctrl+alt+F2 and ctrl+alt+F1 but that did not work.

I have submitted a formal bug. I really appreciate the advice on what additional information is required.

gfreeman gravatar imagegfreeman ( 2014-01-29 20:03:34 -0600 )edit

what is the bug number ? or send us the link to the bug . please , to can help you

sergiomb gravatar imagesergiomb ( 2014-01-30 10:02:48 -0600 )edit
1

It is 1059502

gfreeman gravatar imagegfreeman ( 2014-01-30 14:27:57 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-27 18:20:58 -0600

Seen: 4,090 times

Last updated: May 30 '14