Ask Your Question
1

fedora19 transaction check-error

asked 2014-01-25 14:08:12 -0600

sarahsantos gravatar image

updated 2014-01-26 00:20:24 -0600

FranciscoD_ gravatar image

Running yum update i've got the below listed transaction error, any good advice? The best option to fix this, would be? If any one can help, i would appreciate

Transaction check error:
  file /etc/php-zts.d/zip.ini from install of php-common-5.5.8-1.fc19.x86_64 conflicts with file from package php-pecl-zip-1.12.3-1.fc19.remi.5.5.x86_64
  file /etc/php.d/zip.ini from install of php-common-5.5.8-1.fc19.x86_64 conflicts with file from package php-pecl-zip-1.12.3-1.fc19.remi.5.5.x86_64
  file /usr/lib64/php-zts/modules/zip.so from install of php-common-5.5.8-1.fc19.x86_64 conflicts with file from package php-pecl-zip-1.12.3-1.fc19.remi.5.5.x86_64
  file /usr/lib64/php/modules/zip.so from install of php-common-5.5.8-1.fc19.x86_64 conflicts with file from package php-pecl-zip-1.12.3-1.fc19.remi.5.5.x86_64
edit retag flag offensive close merge delete

Comments

Please use code tags for terminal output. Edit your question to fix that and also give the results of yum list 'php-common' 'php-pecl-zip'

NickTux gravatar imageNickTux ( 2014-01-25 14:52:00 -0600 )edit

Thanks for the tip! As suggested i ran yum list 'php-common' 'php-pecl-zip' and the packages installed were through remi repo. I uninstalled them and upgraded to new ones. Now everything working fine. Thanks for the help.

sarahsantos gravatar imagesarahsantos ( 2014-01-25 16:56:17 -0600 )edit
1

@sarahsantos, thank your helpers by upvoting them or better yet, use the tick mark button to select it as the right answer.

mether gravatar imagemether ( 2014-01-25 20:17:56 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2014-01-25 14:57:35 -0600

NickTux gravatar image

updated 2014-01-26 08:16:02 -0600

Relevant question/answer that might help you. Probably the remi repository causes this error. Try to disable it.

Use the

yum list 'php-common' 'php-pecl-zip'

to list the affected packages. Remove any packages related to remi repository. Disable the repo and install again the packages from the Official repositories.

edit flag offensive delete link more
1

answered 2014-01-26 07:18:15 -0600

wquine gravatar image

The 'remi' repository has packages that conflict with packages from the base repositories. If you're going to use this repository, you need to set up yum repository priorities with the yum-plugin-priorities package.

edit flag offensive delete link more
1

answered 2014-01-28 04:12:32 -0600

Tomas Vahalik gravatar image

Hi, I've had the same problem.

Here is the solution, if someone wants to use @Remi repository for latest php support.

$ sudo vim /etc/yum.repos.d/remi.repo

Your file should look like this:

  1 [remi]
  2 name=Les RPM de remi pour Fedora $releasever - $basearch
  3 #baseurl=http://rpms.famillecollet.com/fedora/$releasever/remi/$basearc
  4 mirrorlist=http://rpms.famillecollet.com/fedora/$releasever/remi/mirror
  5 enabled=0
  6 gpgcheck=1
  7 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Change line 5 to enabled=1 and try to run $ sudo yum update

It should work nicely again.

edit flag offensive delete link more

Comments

Hi, thanks for the tip, by default is disabled, changing the line 5 to enabled=1, modifies to enabled. When i installed the previous packages, i enabled the remi repo and my etc/yum.repos.d/remi.repo, was by default, so theconflict with packages from the base repos.

sarahsantos gravatar imagesarahsantos ( 2014-01-28 18:41:02 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2014-01-25 14:08:12 -0600

Seen: 1,176 times

Last updated: Jan 28 '14