Ask Your Question
0

I cannot log in fedora 20 on gnome-classic

asked 2014-01-25 09:33:56 -0600

mone gravatar image

updated 2014-01-25 18:10:44 -0600

FranciscoD_ gravatar image

hello,I am a beginner of linux.I cannot log in my account of fedora 20.

I wanted to use fedora with gnome-classic. I looked this question and answers and changed the session-name of gnome desktop to gnome-fallback using dconf-editor. Once I logged out my account,then I cannot log buck in! (fedora said "Oh no! Somethig has gone wrong.A problem has occurredand the system can't recover.Please log out and try again.")

Now,I log in fedora by another account.But,I wanted to log in my own account!

So if you have good suggestions,ideas or something to recover it,please tell me !!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-25 11:04:24 -0600

NickTux gravatar image

updated 2014-01-26 08:11:06 -0600

Some things have been changed since Fedora 18 (the answer you linked in your question). So I support that users always must include the version of Fedora in the title of any question.

As you said you can login from another user's account, try to revert the changes you've done in dconf editor for the affected user. I would rename the file .config/dconf/user and/or .config/gconf/ folder (if exist) . The root user can make such changes , but use it wisely.

As for the gnome-classic session, in Fedora 20 you can install a package with relevant name

sudo yum install gnome-classic-session.noarch

and you will see the gnome-classic session listed in GDM.

Proposal: As I have tested this session, I didn't see any significant difference between GNOME and GNOME-CLASSIC , so if you want a lighter DE that is similar to the old gnome2, I would suggest to install MATE in your current Fedora 20.

For a complete installation

sudo yum groups install "MATE Desktop"
edit flag offensive delete link more

Comments

Renaming ~/.config/dconf/user in the affected user account should work. Note that if you install gnome-classic-session you'll get a "GNOME Classic" session option in the session list; you can use that session to both test the classic mode and to reset that session-name key using dconf-editor.

Note in gnome-shell-3.10.x in F20 the "gnome-fallback" mode (which didn't require/use 3d acceleration) has been replaced by the "classic mode" (which still uses gnome-shell with 3d acceleration but uses some gnome-shell extensions to make the desktop "look" similar to the old GNOME2 desktop).

Ahmad Samir gravatar imageAhmad Samir ( 2014-01-26 01:54:57 -0600 )edit

Exactly @Ahmad Samir . So I said there is no difference between gnome-shell and gnome-classic in Fedora 20. I edited the answer about .config/dconf/user file.

NickTux gravatar imageNickTux ( 2014-01-26 08:12:02 -0600 )edit
0

answered 2014-01-26 06:18:28 -0600

mone gravatar image

thanks for your help!!

Now,I enjoy fedora 20 with MATE desktop!

I should have checked the version of fedora... Thank you a lot for teaching!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-01-25 09:33:56 -0600

Seen: 9,056 times

Last updated: Jan 26 '14