Ask Your Question
1

How to enable SNA acceleration method for Intel cards in Fedora 20 ? [closed]

asked 2014-01-24 16:55:29 -0600

NickTux gravatar image

updated 2014-02-13 13:34:35 -0600

mether gravatar image

There are two major acceleration methods for Intel cards. UXA and SNA. The later is newer and gives some advantages. You can see various of benchmarks over the Internet. Example : Openbenchmarking.org

I recently installed Fedora 20 and I saw that the UXA acceleration method is enabled by default. I have an Intel card that supports the SNA acceleration method and I know that Intel driver that is included in Fedora 20 does support this method.

How to enable the SNA acceleration method for my Intel card in Fedora 20 ? Do I have to install any additional software and what configuration must be done ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by NickTux
close date 2014-07-17 10:33:07.859138

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-01-24 17:09:33 -0600

NickTux gravatar image

In order to enable the SNA acceleration method in Fedora 20, a configuration file must be added manually under /etc/X11/xorg.conf.d/ folder.

First of all, check what acceleration method is used in your system by default, by issuing the following command in a terminal

cat /var/log/Xorg.0.log | grep -ie uxa -ie sna

If the UXA is enabled, then run the following command in order to create the configuration file. Superuser privileges are needed here. Copy-paste the following command as one command (no matter if it appears as three lines here) in your terminal.

echo -e 'Section "Device"\n    Identifier  "Intel Graphics"\n    Driver      "intel"\n    Option      "AccelMethod"  "sna"\n    Option      "TearFree"    "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

Reboot your PC and issue (again) the check command

cat /var/log/Xorg.0.log | grep -ie uxa -ie sna

now it should return something like

(II) intel(0): SNA initialized with Ironlake (gen5) backend

If in trouble for any reason, just remove the configuartion file 20-intel.conf from /etc/X11/xorg.conf.d/ and restart the PC.

sudo rm -i /etc/X11/xorg.conf.d/20-intel.conf
edit flag offensive delete link more

Comments

It seems this advice does not work anymore :(

[root@localhost ~]# cat /etc/issue
Fedora release 20 (Heisenbug)
Kernel \r on an \m (\l)

[root@localhost ~]# cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "sna"
    Option      "TearFree"    "true"
EndSection
[root@localhost ~]# cat /var/log/Xorg.0.log | grep -ie uxa -ie sna
[     6.255] (II) UXA(0): Driver registered support for the following operations:
mikhail gravatar imagemikhail ( 2014-06-16 12:59:38 -0600 )edit

It works for me :) Are you sure your Intel model, supports SNA acceleration ? lspci -nnk | grep -iA2 vga and glxinfo | grep OpenGL

NickTux gravatar imageNickTux ( 2014-06-16 17:30:34 -0600 )edit
0

answered 2014-07-17 08:47:31 -0600

Forge gravatar image

updated 2014-07-17 10:32:43 -0600

NickTux gravatar image

Works for me, too, better check that your hardware actually supports SNA first.

[forge@localhost ~]$ cat /etc/issue
Fedora release 20 (Heisenbug)
Kernel \r on an \m (\l)

[forge@localhost ~]$ cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "sna"
    Option      "TearFree"    "true"
EndSection

[forge@localhost ~]$ cat /var/log/Xorg.0.log | grep -ie uxa -ie sna
[  1486.891] (**) intel(0): Option "AccelMethod" "sna"
[  1486.901] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[forge@localhost ~]$
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-24 16:55:29 -0600

Seen: 8,222 times

Last updated: Jul 17 '14