Ask Your Question
1

package dependency error

asked 2014-01-19 14:14:28 -0600

AnatoleG gravatar image

updated 2014-09-30 11:12:33 -0600

mether gravatar image

Hi everyone, Since two weeks, I've faced some troubles for updating my OS (Fedora 20). In fact, I got some dependency errors. Here is a part of the output:

Full update command output:

Loaded plugins: langpacks, refresh-packagekit
http://fedora.vitu.ch/QGIS/20/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
Resolving Dependencies
--> Running transaction check
---> Package cpp.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: cpp = 4.8.2-1.fc20 for package: gcc-4.8.2-1.fc20.x86_64
---> Package cpp.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgcc.x86_64 0:4.8.2-1.fc20 will be updated
---> Package libgcc.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgfortran.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: libgfortran = 4.8.2-1.fc20 for package: gcc-gfortran-4.8.2-1.fc20.x86_64
---> Package libgfortran.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgomp.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: libgomp = 4.8.2-1.fc20 for package: gcc-4.8.2-1.fc20.x86_64
---> Package libgomp.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libjpeg-turbo.x86_64 0:1.3.0-1.fc20 will be updated
---> Package libjpeg-turbo.x86_64 0:1.3.0-2.fc20 will be an update
---> Package libkkc.x86_64 0:0.3.1-2.fc20 will be updated
---> Package libkkc.x86_64 0:0.3.2-1.fc20 will be an update
---> Package libkkc-common.noarch 0:0.3.1-2.fc20 will be updated
---> Package libkkc-common.noarch 0:0.3.2-1.fc20 will be an update
---> Package libldb.x86_64 0:1.1.16-3.fc20 will be updated
---> Package libldb.x86_64 0:1.1.16-4.fc20 will be an update
---> Package libodfgen.x86_64 0:0.0.3-1.fc20 will be updated
---> Package libodfgen.x86_64 0:0.0.4-1.fc20 will be an update
---> Package libpcap.x86_64 14:1.5.0-1.20131108git459712e.fc20 will be updated
---> Package libpcap.x86_64 14:1.5.3-1.fc20 will be an update
---> Package libpciaccess.x86_64 0:0.13.1-4.fc20 will be updated
---> Package libpciaccess.x86_64 0:0.13.2-1.fc20 will be an update
---> Package libquadmath.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: libquadmath = 4.8.2-1.fc20 for package: gcc-gfortran-4.8.2-1.fc20.x86_64
--> Processing Dependency: libquadmath = 4.8.2-1.fc20 for package: libgfortran-4.8.2-1.fc20.i686
---> Package libquadmath.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libquadmath-devel.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: libquadmath-devel = 4.8.2-1.fc20 for package: gcc-gfortran-4.8.2-1.fc20.x86_64
---> Package libquadmath-devel.x86_64 0:4.8.2-7.fc20 will be an update
--> Processing Dependency: gcc = 4.8.2-7.fc20 for package: libquadmath-devel-4.8.2-7.fc20.x86_64
---> Package libssh.x86_64 0:0.5.5-1.fc20 will be updated
---> Package libssh.x86_64 0:0.6.0-1.fc20 will be an update
---> Package libsss_nss_idmap.x86_64 0:1.11.2-1.fc20 will be updated
---> Package libsss_nss_idmap.x86_64 0:1 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Partial output is unhelpful. We need the full output to see what you are trying to install in the first place.

mether gravatar imagemether ( 2014-01-19 15:36:24 -0600 )edit

It will be helpful to know if this is a fresh Fedora install, or an upgrade or something. We need to know the package that you're trying to install before we can make a diagnosis, as @mether already pointed out.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-21 06:02:38 -0600 )edit

I upgraded from f19 to f20 two months ago without troubles using Fedup. Here is my full output after "yum update"

Loaded plugins: langpacks, refresh-packagekit
http://fedora.vitu.ch/QGIS/20/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
Resolving Dependencies
--> Running transaction check
---> Package cpp.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: cpp = 4.8.2-1.fc20 for package: gcc-4.8.2-1.fc20.x86_64
---> Package cpp.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgcc.x86_64 0:4.8.2-1.fc20 will be updated
---> Package libgcc.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgfortran.x86_64 0:4.8.2-1.fc20 will be updated
--> Processing Dependency: libgfortran = 4.8.2-1.fc20 for package: gcc-gfortran-4.8.2-1.fc20.x86_64
---> Package libgfortran.x86_64 0:4.8.2-7.fc20 will be an update
---> Package libgomp.x86_64 ...
(more)
AnatoleG gravatar imageAnatoleG ( 2014-01-21 07:34:07 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-20 18:14:31 -0600

sergiomb gravatar image

you may try do just a partial update like :

yum update gcc --skip-broken

seems some package say that need gcc-4.8.2-1.fc20 instead 4.8.2-7.fc20

edit flag offensive delete link more

Comments

Here is the output: Loaded plugins: langpacks, refresh-packagekit http://fedora.vitu.ch/QGIS/20/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found Trying other mirror. No Match for argument: gcc No package gcc available. No packages marked for update

AnatoleG gravatar imageAnatoleG ( 2014-01-21 07:42:21 -0600 )edit
0

answered 2014-01-22 05:49:56 -0600

AnatoleG gravatar image

Hi everyone, Just to inform you that my problem is solved. The solution is a proposition from Heldwin (find it here ). It's in three steps: 1- Erased packages which update involved Processing Dependency

rpm -e --nodeps libquadmath-devel libquadmath libgomp libgfortran gcc libstdc++ cpp

2- Install them (erased packages)

yum install libquadmath-devel libquadmath libgomp libgfortran gcc libstdc++ cpp

3- Run update

yum update

That's that!!

Thank you

edit flag offensive delete link more

Comments

yeah that is one correct any to do it .

sergiomb gravatar imagesergiomb ( 2014-01-22 10:39:38 -0600 )edit

worked for me (with another package), thanks!

jago gravatar imagejago ( 2015-09-10 09:07:46 -0600 )edit

Question Tools

Stats

Asked: 2014-01-19 14:14:28 -0600

Seen: 1,857 times

Last updated: Jan 22 '14