fedora 20 yum extender and yum update [closed]

asked 2014-01-18 06:17:16 -0600

jim gravatar image

updated 2014-04-14 15:19:10 -0600

mether gravatar image

I am having problems using yum extender, it kept hanging and appears to want input from the user. The problem seemed initially to be with the package nfs-utils-1.2.9-2.1.fc20.x86_64.rpm

I then logged in as su and used the command yum update but got the message: "Total 556 kB/s | 4.5 MB 00:00:08
Running transaction check Running transaction test Transaction test succeeded Running transaction error: %pre(tcpdump-14:4.5.1-1.fc20.x86_64) scriptlet failed, exit status 127 Error in PREIN scriptlet in rpm package 14:tcpdump-4.5.1-1.fc20.x86_64 error: tcpdump-14:4.5.1-1.fc20.x86_64: install failed error: %pre(initscripts-9.51-1.fc20.x86_64) scriptlet failed, exit status 127 Error in PREIN scriptlet in rpm package initscripts-9.51-1.fc20.x86_64 error: initscripts-9.51-1.fc20.x86_64: install failed error: %pre(selinux-policy-targeted-3.12.1-117.fc20.noarch) scriptlet failed, exit status 127 Error in PREIN scriptlet in rpm package selinux-policy-targeted-3.12.1-117.fc20.noarch error: selinux-policy-targeted-3.12.1-117.fc20.noarch: install failed error: %pre(nfs-utils-1:1.2.9-2.1.fc20.x86_64) scriptlet failed, exit status 127 Error in PREIN scriptlet in rpm package 1:nfs-utils-1.2.9-2.1.fc20.x86_64 Verifying : 1:nfs-utils-1.2.9-2.1.fc20.x86_64 1/8 Verifying : selinux-policy-targeted-3.12.1-117.fc20.noarch 2/8 selinux-policy-targeted-3.12.1-116.fc20.noarch was supposed to be removed but is not! Verifying : selinux-policy-targeted-3.12.1-116.fc20.noarch 3/8 initscripts-9.50-1.fc20.x86_64 was supposed to be removed but is not! Verifying : initscripts-9.50-1.fc20.x86_64 4/8 Verifying : initscripts-9.51-1.fc20.x86_64 5/8 1:nfs-utils-1.2.8-6.0.fc20.x86_64 was supposed to be removed but is not! Verifying : 1:nfs-utils-1.2.8-6.0.fc20.x86_64 6/8 14:tcpdump-4.5.0-1.20131108gitb07944a.fc20.x86_64 was supposed to be removed but is not! Verifying : 14:tcpdump-4.5.0-1.20131108gitb07944a.fc20.x86_64 7/8 Verifying : 14:tcpdump-4.5.1-1.fc20.x86_64 8/8

Failed: initscripts.x86_64 0:9.50-1.fc20 initscripts.x86_64 0:9.51-1.fc20 nfs-utils.x86_64 1:1.2.8-6.0.fc20
nfs-utils.x86_64 1:1.2.9-2.1.fc20 selinux-policy-targeted.noarch 0:3.12.1-116.fc20 selinux-policy-targeted.noarch 0:3.12.1-117.fc20
tcpdump.x86_64 14:4.5.0-1.20131108gitb07944a.fc20 tcpdump.x86_64 14:4.5.1-1.fc20

Complete!"

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by mether
close date 2014-01-18 23:07:46.687510

Comments

It's this problem: https://ask.fedoraproject.org/question/39213/ . In you case i guess you already have a failed update of selinux-policy installed, so start with downgrading and updating selinux-policy, see my comment below "You can see the yum history and reinstall packages with scriptlet errors. That's the best bet."

marcindulak gravatar imagemarcindulak ( 2014-01-18 08:05:05 -0600 )edit