Ask Your Question
1

Cannot retrieve metalink for repository: fedora/20/x86_64. Please verify its path and try again [closed]

asked 2014-01-10 13:01:18 -0600

florian gravatar image

updated 2014-10-06 07:53:06 -0600

FranciscoD_ gravatar image

This question became obsolete: Why? Find out below ...

Hi, I'm trying to update my package information from shell using sudo yum update. It returns the following error.

Cannot retrieve metalink for repository: fedora/20/x86_64. Please verify its path and try again.

What could be wrong with it? Florian

What was wrong?

I had encountered the problem described above at my work place (yes, right, I shouldn't do private stuff there), but when I returned home later today everything was working perfectly fine. I assume that our company's filter (proxy: zscaler.com) caused some problems reaching the servers.

edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by florian
close date 2015-01-09 11:30:36.770434

Comments

You could try sudo yum clean all to purge cache and metadata. Or - and I know this is a long shot - did you change anything in the /etc/yum.repo.d/ files?

mithrial gravatar imagemithrial ( 2014-01-10 13:09:13 -0600 )edit

I think it was a problem with the proxy/filter of my company's network. Back home sudo yum update worked perfectly. How can I delete this question? Sorry for asking stupid questions!

florian gravatar imageflorian ( 2014-01-11 00:51:38 -0600 )edit
1

@Florian - since you found and resolved your issue, I suggest you rephrase your question and post and answer that shows how you discovered the solution and what you did to resolve it. That way, future readers can try your solution for their own problems.

randomuser gravatar imagerandomuser ( 2014-01-11 01:05:06 -0600 )edit

Just a note - yum can work with http proxies. Please read man yum.conf for more information. I'm closing this question. It'd be better if you could provide the answer as one so that it could be marked as correct, though.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-24 04:02:53 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2014-06-28 21:49:49 -0600

al_lapalme gravatar image

I know I'm late replying but I came across this exact error, but the error was caused by the time being incorrectly set on the computer. (Oct, 2009 instead of June, 2014). I corrected the time and ran yum again; it completed successfully.

edit flag offensive delete link more
1

answered 2014-10-22 20:03:32 -0600

computermed3111 gravatar image

Florian: I had the same issue as you and of course I went home and tried in a virtual machine and it worked also. So I agree that the problem you had was that your company's network was blocking the connection to the mirror link websites. My company filters traffic through a proxy as well, and that is the only answer now that makes any sense. The sad thing is we are a school and we have students interested in learning Linux. So now I can make the case to the powers to unlock access to the URLs. Thanks for sharing your comments. I will vote up your answer soon as I register. --heisenberg

edit flag offensive delete link more
0

answered 2014-01-10 13:11:59 -0600

At least one of the listed repositories doesn't have a package or the package metadata (repodata/repomd.xml) for Fedora 20. The simple solution is to go to /etc/yum.repos.d/ directory and comment out the out of date sources, with

sudo nano /etc/yum.repos/d

but you can search here on "yum doesn't work after upgrade to F20" for more detail.

edit flag offensive delete link more

Comments

I think it was a problem with the proxy/filter of my company's network. Back home sudo yum update worked perfectly. How can I delete this question? Sorry for asking stupid questions!

florian gravatar imageflorian ( 2014-01-11 00:50:21 -0600 )edit

The repo definitions do not contain a list of mirrors. They have metalink, which redirects yum to a mirror.

randomuser gravatar imagerandomuser ( 2014-01-11 01:03:10 -0600 )edit
-3

answered 2014-10-03 22:22:52 -0600

yuzda gravatar image

change selinux to disabled

edit flag offensive delete link more

Comments

Huh? Please don't. This issue has nothing to do with selinux.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 07:50:54 -0600 )edit

Question Tools

Stats

Asked: 2014-01-10 13:01:18 -0600

Seen: 28,654 times

Last updated: Oct 22 '14