Ask Your Question
0

Fedora 19 yum update repomd.xml does not match metalink for updates.

asked 2014-01-10 03:34:31 -0600

ducaz gravatar image

updated 2014-01-20 18:30:39 -0600

FranciscoD_ gravatar image

Hello Everyone,

I am having an error while i am trying to "yum update"

fedora.mirrors.ovh.net/linux/updates/19/x86_64/repodata/repomd.xml:
[Errno -1] repomd.xml does not match metalink for updates Trying other mirror.

and that fails my update , i tried yum clean all , yum clean metadata. Didn't solve my problem. These are my repository settings.

[fedora] name=Fedora $releasever -
$basearch failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1 metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

[fedora-debuginfo] name=Fedora
$releasever - $basearch - Debug
failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=1 metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

[fedora-source] name=Fedora
$releasever - Source
failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=1 metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

[updates] name=Fedora $releasever -
$basearch - Updates
failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1 gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable = 1 keepcache = 0

[updates-debuginfo] name=Fedora
$releasever - $basearch - Updates -
Debug failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch
enabled=1 gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

[updates-source] name=Fedora
$releasever - Updates Source
failovermethod=priority
baseurl=download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
mirrorlist=mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch
enabled=1 gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
edit retag flag offensive close merge delete

Comments

all baseurl links start with http://

ducaz gravatar imageducaz ( 2014-01-10 03:35:04 -0600 )edit

and all mirrorlist links start with https://

ducaz gravatar imageducaz ( 2014-01-10 03:35:21 -0600 )edit

Typically you would use either baseurl or mirrorlist, and the other would be #commented out with a hash. Is that the case with your configuration?

randomuser gravatar imagerandomuser ( 2014-01-11 00:38:58 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-01-20 18:04:26 -0600

sergiomb gravatar image
edit flag offensive delete link more
0

answered 2014-01-20 18:33:21 -0600

FranciscoD_ gravatar image

I think you've played with your configuration files. A sudo yum reinstall fedora-release followed by sudo rpmconf -a to ensure pristine configuration files are installed would be the way to go. Basically, undo whatever changes you made to the files and use the stock fedora ones and it'll work just fine.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-10 03:34:31 -0600

Seen: 1,280 times

Last updated: Jan 20 '14