Ask Your Question
1

fedora 20 resolution issue

asked 2014-01-03 12:02:12 -0600

NikhilK gravatar image

updated 2014-09-29 00:07:30 -0600

mether gravatar image

I have recently installed fedora 20 in my laptop (Dell Inspiron N4010 - intel integrated Graphics Card). The maximum resolution that i can select is 1024 x 768. However laptop supports resolutions up to 1368 x 768.

I have installed Ubuntu 13.10 (I'm dual booting my system) and i can select 1368 x 768 in ubuntu.

In fedora i tried using xrandr tool But when i use following command...

xrandr --newmode "1368x768R" 72.25 1368 1416 1448 1528 768 771 781 790 +hsync -vsync

Its showing a error xrandr: Failed to get size of gamma for output default

Is it possible to resolve this issue.

Edit : Contents of /var/log/Xorg.0.log http://ur1.ca/gbs7u

edit retag flag offensive close merge delete

Comments

Posting the contents of /var/log/Xorg.0.log to a pastebin (e.g. http://fpaste.org) should be useful to debug this issue.

Ahmad Samir gravatar imageAhmad Samir ( 2014-01-04 02:53:26 -0600 )edit

Thanks.. i have copied the contents of /var/log/Xorg.0.log to http://fpaste.com Please see the link http://ur1.ca/gbs7u

NikhilK gravatar imageNikhilK ( 2014-01-04 05:08:32 -0600 )edit
1

IINM, it's using the vesa driver instead of the intel driver for some reason. What's the output of 'xrandr' and 'lspci | grep -i vga'.

Ahmad Samir gravatar imageAhmad Samir ( 2014-01-04 06:49:11 -0600 )edit

ok... Is there any way to force system to use intel drivers ? Please see the output of xrandr and lspci | grep -i vga - http://ur1.ca/gbw69 Thanks again for your reply.

NikhilK gravatar imageNikhilK ( 2014-01-04 08:55:30 -0600 )edit
davidva gravatar imagedavidva ( 2014-01-05 23:04:44 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-01-04 11:50:38 -0600

Ahmad Samir gravatar image

updated 2014-01-05 10:38:24 -0600

First of all, to be able to revert the changes (if you don't get a graphical GUI at all due to the changes you'll make), make sure you're able to go to text console by pressing Alt+Ctrl+F2; or alternatively, that you have access to the system via a live CD... etc.

So, to force the system to use the intel driver, as root create /etc/X11/xorg.conf and put this in it:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
EndSection

save the file and log out for the changes to take effect.

If you don't get a graphical desktop at all, go to tty2 (Alt+Ctrl+F2), log in as root and delete /etc/X11/xorg.conf.

EDIT: I've totally missed it in your Xorg.0.log, right at the top, nomodeset is present in the kernel command line, the intel driver needs KMS (kernel mode setting) to work, and nomodeset disables KMS.

To test, when booting, at the boot loader - GRUB - screen edit the entry you're booting and remove nomodeset; see if it boots and uses the correct resolution for your laptop, which means the X server will be able to automatically select the intel driver.

If it does, you can edit /boot/grub2/grub.cfg and remove nomodeset from the kernel(s) command line. And then check /etc/default/grub to make sure it doesn't have nomodeset (so that if you ever need to create a new grub.cfg with grub2-mkconfig, nomodeset isn't re-added).

edit flag offensive delete link more

Comments

Thanks but that didn't help. Gnome was not loading after creating the file xorg.conf with the said settings. Is there a way to check if intel drivers are installed nor not in my system. I'm beginning to believe that intel drivers are not installed.

NikhilK gravatar imageNikhilK ( 2014-01-05 07:48:29 -0600 )edit

I have executed the command yum list installed and found following line xorg-x11-drv-intel.x86_64 2.21.9-5.3 @intellinuxgraphics . Is it the intel open source driver ?

NikhilK gravatar imageNikhilK ( 2014-01-05 08:00:49 -0600 )edit
1

try booting with the kernel commandline vesa=off

ILMostro gravatar imageILMostro ( 2014-02-01 05:22:03 -0600 )edit

Thanks that fixed the issue.. I have installed latest Intel Graphics drivers using the intels offical installed and removed the nomodeset and as Samir suggested and added vesa=off as per ILMostro's suggestion... Thanks a lot guys...

NikhilK gravatar imageNikhilK ( 2014-03-29 01:05:14 -0600 )edit

I think the vesa=off boot option is not needed here, since the system will be using the intel driver automatically.

Ahmad Samir gravatar imageAhmad Samir ( 2014-03-29 06:12:21 -0600 )edit

Question Tools

Stats

Asked: 2014-01-03 12:02:12 -0600

Seen: 6,107 times

Last updated: Jan 05 '14