Ask Your Question
1

Fedora 19 disappeared on GRUB; switched to Ubuntu boot loader

asked 2013-12-26 23:58:21 -0600

nrwahl gravatar image

updated 2013-12-29 00:27:22 -0600

FranciscoD_ gravatar image

Hi guys. I've been booting Fedora 19, Ubuntu 12.04, and Windows 7. I started with Windows, then installed Ubuntu, then most recently installed Fedora.

Since I installed Fedora, Fedora's boot loader has appeared, and all three OS's have been listed in GRUB. This has worked for several weeks. Yesterday, however, I shut down Ubuntu using the off button while at the login stage of the tty2 shell. Since then, every boot has resulted in the damn purple Ubuntu boot loader, and Fedora is completely missing from GRUB. I don't know how to boot into Fedora now. I really don't think the whole partition got erased, but I can't access it.

Can you guys help me out? Thanks in advance.

P.S. Sorry if I misused any terms like a dumbass. I'm fairly new to Linux and whatnot.

edit retag flag offensive close merge delete

Comments

Should I run

grub2-mkconfig -o /boot/grub2/grub.cfg

on Ubuntu? That's the only thing I saw from answers to other questions that I thought might apply.

nrwahl gravatar imagenrwahl ( 2013-12-27 00:23:08 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-29 00:24:24 -0600

FranciscoD_ gravatar image

Yep. The command you found should do it. This page has details on how to go about it.

The issue here is that every time you receive a kernel upgrade in ubuntu it'll probably overwrite the grub configuration. You need to head to fedora and re-generate the grub configuration when this happens.

edit flag offensive delete link more

Comments

I can't head to Fedora except on a live DVD. I tried running the above command there. The above command doesn't work on Ubuntu--I have to change the "grub2"s to "grub"s. In both instances, the os-prober didn't find my Fedora partition.

I believe Fedora is/was on /dev/sda8 (could be wrong). The os-prober in Ubuntu found Windows 7 on /dev/sda2 and Ubuntu wherever the hell it was. I really doubt my whole Fedora OS got erased but none of these auto-config attempts are finding it. I read the article you linked me to. This might be relevant:

nrwahl gravatar imagenrwahl ( 2013-12-29 03:40:38 -0600 )edit

(https://fedoraproject.org/wiki/GRUB_2?rd=Grub2#Encountering_the_dreaded_GRUB_2_boot_prompt) but if so, I can't figure out how to use it.

I'm doing my best here but this is all I've got for you. I'll try anything you suggest and answer any questions you have though.

nrwahl gravatar imagenrwahl ( 2013-12-29 03:40:49 -0600 )edit
0

answered 2013-12-29 13:23:39 -0600

elegantuni gravatar image

updated 2013-12-29 13:27:57 -0600

Press c at the grub bootloader. Then type ls. Look at which partition would have the /boot directory of fedora on it. You said it is probably on /dev/sda8 so it is probably hd0,msdos8 if the /boot isn't separate from / .If it isn't separate and is hd0,msdos8 type

set root=(hd0,msdos8)

Then type

linux /boot/vmlinuz-(press tab twice and use the one you want) root=/dev/sda8

Then type

initrd /boot/initramfs-(same as previous even the dashes and architecture type).img

Then type

boot

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-26 23:58:21 -0600

Seen: 861 times

Last updated: Dec 29 '13