Ask Your Question
1

USB sound card as default (Fed 19)

asked 2013-12-25 15:21:26 -0600

schorsch gravatar image

updated 2014-04-11 16:52:26 -0600

remjg gravatar image

Hi! I'm running Fedora 19. I got a creative "soundblaster audigy 2 nx". I did not install a specific driver. It works in SMPlayer after changing the output device in the program to my usb sound card. Other programs I want to work with do not show a simple option like this; How can I make the USB soundcard the default for all sounds?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-12-26 21:43:30 -0600

elegantuni gravatar image

updated 2013-12-27 18:52:34 -0600

remjg gravatar image

You can try aplay -l it will give you something like this:

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]
  Subdevices: 1/1

Then you would create a .asoundrc file in your users home directory with something like (using card 1):

pcm.!default front:Generic_1
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-25 15:21:26 -0600

Seen: 1,333 times

Last updated: Dec 27 '13