Ask Your Question
3

How to disable Selinux in Fedora 20?

asked 2013-12-24 05:44:03 -0600

Bucic gravatar image

updated 2013-12-27 23:59:23 -0600

FranciscoD_ gravatar image

I've disabled Selinux as per https://ask.fedoraproject.org/question/10507/how-to-disable-fedora-17-selinux/ and I'm still getting 'error' messages in the 'tray' from it. How do I stop it?

The contents of my /etc/selinux/config:

# This file controls the state of SELinux on the system.
# SELINUX=permissive
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     minimum - Modification of targeted policy. Only selected processes are protected. 
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

And

$ selinuxenabled && echo enabled || echo disabled enabled

PS. I do know that I shouldn't disable Selinux. Please respect the question.

edit retag flag offensive close merge delete

Comments

Did you reboot after the change? You can use the getenforce command to check the status of selinux, rather than checking the return value of selinuxenabled

FranciscoD_ gravatar imageFranciscoD_ ( 2013-12-24 06:37:52 -0600 )edit
2

I also can't disable it by editing /etc/selinux/config. Output of sestatus:

$ sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   permissive
Mode from config file:          disabled
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      28

Does anybody have a solution for it?

Andrey L. gravatar imageAndrey L. ( 2013-12-24 06:38:36 -0600 )edit

I did, several times.

Bucic gravatar imageBucic ( 2013-12-24 06:56:12 -0600 )edit
1

I realize Selinux puts you in trouble, but its a great security feature. If you can solve your problem by fixing your software rather than selinux itself, that the safest option for you, if you are concerned with security.

jayaura gravatar imagejayaura ( 2013-12-27 23:00:55 -0600 )edit

6 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-27 23:58:35 -0600

FranciscoD_ gravatar image

Please see https://bugzilla.redhat.com/show_bug.cgi?id=1046470 for more information.

edit flag offensive delete link more
1

answered 2013-12-25 06:19:58 -0600

k.tateishi gravatar image

Hi,

I was in the same situation since upgrading libselinux to 2.2.1-4.fc20. If you installed libselinux-2.2.1-4.fc20, try following workaround:

(a) yum downgrade 'libselinux*' (of course you need to reboot)

If not, you should try:

(b) Add selinux=0 to your kernel option

edit flag offensive delete link more

Comments

Confirming. This is a bug and an update is on the way to fix it.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-12-27 23:57:06 -0600 )edit
1

Thanks for the info. Now we have third option: update to libselinux-2.2.1-6.fc20

k.tateishi gravatar imagek.tateishi ( 2013-12-28 01:32:10 -0600 )edit

@FranciscoD_ Could you convert your comment into an answer so I can accept it?

Bucic gravatar imageBucic ( 2014-01-02 07:45:49 -0600 )edit
1

answered 2013-12-24 06:30:49 -0600

deusdara gravatar image

Hi

I made that change as root and I dont have error messages.

edit flag offensive delete link more
0

answered 2013-12-25 19:43:06 -0600

quantenselbstmord gravatar image

your selinux conf it's OK , try run as root setenforce 0 :)

edit flag offensive delete link more
0

answered 2013-12-28 02:05:49 -0600

I changed /etc/selinux/config file by changing SELINUXTYPE=targeted to disabled then rebooted. The boot process starts, but hangs. Last message is: "[OK] Reached initrd target default target."

Then nothing. Left it sit 20 minutes. Next, I booted from the LiveCD, mounted my boot directory, changed the SELINUXTYPE in /a/etc/selinux/config and rebooted. Hung.

Reinstalled from the LiveCD. After it loaded, I booted twice to make sure it could boot. Changed SELINUXTYPE=disabled again. Rebooted. It hangs.

The definition of insanity is doing the same thing over-and-over while expecting a different result.

Mark

edit flag offensive delete link more

Comments

I fail to see how this is an answer to this question. Please open a new question. Your issue isn't the same as the one reported here.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-12-28 18:26:57 -0600 )edit

You may try to see more specifically the problem of freezing. Inspect the boot log. Use journalctl -b -1 to get the log of the previous boot

jayaura gravatar imagejayaura ( 2013-12-30 04:26:51 -0600 )edit
-1

answered 2013-12-27 22:19:06 -0600

Charles Wang gravatar image

How about remove 'Selinux" ???

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-24 05:44:03 -0600

Seen: 33,381 times

Last updated: Dec 28 '13