Ask Your Question
1

How to change the keyboard layout permanently?

asked 2013-12-23 21:25:48 -0500

Black_Bucket gravatar image

updated 2013-12-24 19:03:35 -0500

Hello. I just installed Fedora 20 on my laptop and am having an annoying problem with the keyboard layout. I want to us the 'Spanish - Latin America' layout, so I go to 'Settings -> Keyboard', uncheck the 'Use system defaults' box and erase the 'English (USA)' layout from the list below, leaving only the layout I want. Everything seems to work fine when I am logged in, but if I restart my computer, when Fedora asks me for my account's password, then I am back with the 'English (USA)' layout.

So my question is: how can I set as default the 'Spanish - Latin America' layout permanently in my whole system?

Thanks.


UPDATE: Okay, the thread @deusdara linked helped me to solve my problem. Even though, I had a minor obstacle that I wanted to share with you: reading the aforementioned thread I realized that system-config-keyboard was the tool I needed to use to change the layout. So I went applications menu -> administration -> keyoboard and Fedora asked me to authenticate to run system-config-keyboard; I provided the root's password and the little window dissapeared as it does when you provide the correct password. However nothing happened after that: no application was opened, no message was shown, nothing. I tried a couple of times until I decided to try with the command line and there everything worked fine and I could change the layout correctly. But I was a little confused as to why I couldn't do it via graphical interface. Any idea?

Thanks.

edit retag flag offensive close merge delete

Comments

Rather ask a new question than update this one with a different question.

jcuenod gravatar imagejcuenod ( 2013-12-25 09:08:02 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-24 16:15:28 -0500

deusdara gravatar image

Hi

Please see that thread.

In Fedora, how do I select a proper Norwegian keyboard layout?

http://unix.stackexchange.com/questions/104217/in-fedora-how-do-i-select-a-proper-norwegian-keyboard-layout

edit flag offensive delete link more

Comments

Thank you. I could set the layout the way I wanted.

Black_Bucket gravatar imageBlack_Bucket ( 2013-12-24 19:04:22 -0500 )edit
1

answered 2013-12-29 10:29:04 -0500

elegantuni gravatar image

If you didn't have the graphical way or localectl. You could edit or create the file /etc/locale.conf and if you were en_US.UTF-8 (replace with the Spanish-Latin America equivalent). You would place in /etc/locale.conf

LANG="en_US.UTF-8"

Also you would edit or create the file /etc/vconsole.conf and if you were in the U.S.A (replace with the Spanish-Latin America equivalent). You would place in /etc/vconsole.conf

KEYMAP=us

Now you would have to reboot and it would be saved.

edit flag offensive delete link more
0

answered 2013-12-24 14:37:20 -0500

To set a keyboard layout you need to use Settings -> Region and Language (I see that you can get there from Keyboard though). You then add the keyboard layout you want to use.

At the top of the screen (kind of in the titlebar) there is also a button for Login Screen in which it seems you can set up custom options for the login screen (I must admit, I haven't used it).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-23 21:25:48 -0500

Seen: 33,464 times

Last updated: Dec 29 '13