Ask Your Question
0

I can not install a printer driver

asked 2013-12-23 15:43:08 -0600

peter150 gravatar image

updated 2014-03-29 09:06:48 -0600

mether gravatar image

I work with Fedora 20 and I have a Canon printer pixma ip 2500, the drivers are cnijfilter-common-2.70-1.i386.rpm I can install it,but the cnijfilter-ip2500series-2.70-1.i386.rpm is not to install The error messages are cnijfilter-ip2500series-2.70-1.i386 necessary libpng.so.3, libtiff.so.3 the new version is installed there from, the computer is 64 bit. I would like some help so I can use this printer

edit retag flag offensive close merge delete

5 Answers

Sort by » oldest newest most voted
0

answered 2014-01-06 12:33:46 -0600

wquine gravatar image

I took a look at the package, and it has requirements on a version of libpng and libjpeg not available in Fedora 20. This package is from 2007, and you really don't want to be installing older versions of software for this broken package.

I would suggest trying to get the printer to work with the open source CUPS drivers, and if that doesn't work, contact the vendor to get them to build a version that works with Fedora. It might be possible to just extract the PPD from the RPM, and use it without the rest of the package, which appears to contain software libraries for some sort of application for managing the printer.

edit flag offensive delete link more
0

answered 2015-12-28 11:31:27 -0600

I created a libtiff3 copr project so installing libtiff3 should be as simple as

$ dnf copr enable jpopelka/libtiff3; dnf install libtiff3
edit flag offensive delete link more
0

answered 2013-12-23 17:31:18 -0600

jmt gravatar image

You can easily install the dependencies along with the package on the local disk using yum:

yum install cnijfilter-common-2.70-1.i386.rpm
edit flag offensive delete link more

Comments

he cnijfilter-common-2.70-1.i386.rpm can I install only the cnijfilter-ip2500series-2.70-1.i386 not that you can see in the printout of the instalation

peter150 gravatar imagepeter150 ( 2014-01-06 10:44:03 -0600 )edit
-1

answered 2013-12-25 04:35:58 -0600

peter150 gravatar image

updated 2014-01-06 12:25:52 -0600

wquine gravatar image

dutch

[root@localhost ~]# yum install /home/peter150/Downloads/cnijfilter-ip2500series-2.70-1.i386.rpm --skip-broken
Geladen plugins: langpacks, refresh-packagekit
Onderzoeken /home/peter150/Downloads/cnijfilter-ip2500series-2.70-1.i386.rpm: cnijfilter-ip2500series-2.70-1.i386
Markeren /home/peter150/Downloads/cnijfilter-ip2500series-2.70-1.i386.rpm om te installeren
Oplossen van afhankelijkheden
--> Transactiecontrole uitvoeren
---> Pakket cnijfilter-ip2500series.i386 0:2.70-1 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libX11.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libXext.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libXi.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libgdk-1.2.so.0 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libglib-1.2.so.0 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libgmodule-1.2.so.0 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libgtk-1.2.so.0 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libpng.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libtiff.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libxml.so.1 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Transactiecontrole uitvoeren
---> Pakket cnijfilter-ip2500series.i386 0:2.70-1 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libpng.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libtiff.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
---> Pakket glib.i686 1:1.2.10-40.fc20 wordt geïnstalleerd
---> Pakket gtk+.i686 1:1.2.10-76.fc20 wordt geïnstalleerd
---> Pakket libX11.i686 0:1.6.1-1.fc20 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libxcb.so.1 voor pakket: libX11-1.6.1-1.fc20.i686
---> Pakket libXext.i686 0:1.3.2-2.fc20 wordt geïnstalleerd
---> Pakket libXi.i686 0:1.7.2-2.fc20 wordt geïnstalleerd
---> Pakket libxml.i686 1:1.8.17-32.fc20 wordt geïnstalleerd
--> Transactiecontrole uitvoeren
---> Pakket cnijfilter-ip2500series.i386 0:2.70-1 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libpng.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libtiff.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
---> Pakket libxcb.i686 0:1.9.1-3.fc20 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libXau.so.6 voor pakket: libxcb-1.9.1-3.fc20.i686
--> Transactiecontrole uitvoeren
---> Pakket cnijfilter-ip2500series.i386 0:2.70-1 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libpng.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libtiff.so.3 voor pakket: cnijfilter-ip2500series-2.70-1.i386
---> Pakket libXau.i686 0:1.0.8-2.fc20 wordt geïnstalleerd

Pakketten overgeslagen vanwege afhankelijkheidsproblemen:
    cnijfilter-ip2500series-2.70-1.i386 van /cnijfilter-ip2500series-2.70-1.i386
    1:glib-1.2.10-40.fc20.i686 van fedora
    1:gtk+-1.2.10-76.fc20.i686 van fedora
    libX11-1.6.1-1.fc20.i686 van fedora
    libXau-1.0.8-2.fc20.i686 van fedora
    libXext-1.3.2-2.fc20.i686 van fedora
    libXi-1.7.2-2.fc20.i686 van fedora
    libxcb-1.9.1-3.fc20.i686 van fedora
    1:libxml-1.8.17-32.fc20.i686 van fedora
[root@localhost ~]# yum install /home/peter150/Downloads/cnijfilter-ip2500series-2.70-1.i386.rpm 
Markeren /home/peter150/Downloads/cnijfilter-ip2500series-2.70-1.i386.rpm om te installeren                                                                  
Oplossen van afhankelijkheden
--> Transactiecontrole uitvoeren
---> Pakket cnijfilter-ip2500series.i386 0:2.70-1 wordt geïnstalleerd
--> Verwerking afhankelijkheid: libX11.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libXext.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libXi.so.6 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libgdk-1.2.so.0 voor pakket: cnijfilter-ip2500series-2.70-1.i386
--> Verwerking afhankelijkheid: libglib-1 ...
(more)
edit flag offensive delete link more

Comments

You really should add this to the question, it is not an answer.

wquine gravatar imagewquine ( 2014-01-06 12:27:11 -0600 )edit
-1

answered 2014-01-06 10:41:56 -0600

peter150 gravatar image

updated 2014-01-06 10:44:28 -0600

he cnijfilter-common-2.70-1.i386.rpm can I install only the cnijfilter-ip2500series-2.70-1.i386 not that you can see in the printout of the instalation

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-23 15:43:08 -0600

Seen: 1,778 times

Last updated: Mar 28 '14