Ask Your Question
0

Root password does not work after installation of fedora 20

asked 2013-12-18 08:13:31 -0600

barkas gravatar image

Hey guys, this is my first post here and i have a problem. I have a complete new setup of fedora 20. I installed everything pretty normal i think. I set my root pw and created a user. But i am just not able to use a line like "sudo yum upgrade" in my terminal. It always says "Sorry try again". It is just not working. I tried different Keyboards (Like German, UK..), i used my normal login, i installed it 3-4 times. Tried different pws, created a admin, a normal user. I just don't know what to do now. I hope you are able to help me! Sorry for my English, i know it is not the best..

Hanno

edit retag flag offensive close merge delete

Comments

How can you create additional users without having admin rights in the first place? My first suggestion is that you used another keyboard scheme by creating the password than now, or easier, you (accidentally) turned on Caps lock.

mithrial gravatar imagemithrial ( 2013-12-18 08:20:48 -0600 )edit

Yeah i thought that too.. But it seems that is not the problem. I tried different schemes and capslock.. Also i See i can login AS root in the user Option in GNOME. But not in the terminal.. Also while the Installation shall i create a Armin user? Or a normal?

barkas gravatar imagebarkas ( 2013-12-18 08:34:01 -0600 )edit

Are you in the wheel group? the wheel group have access via sudo to execute commands as root

ezq gravatar imageezq ( 2013-12-18 09:49:07 -0600 )edit
1

If you're using sudo, it expects your password, not root's. And, of course, to use sudo you either need to have set your user account up as an administrator or you need to have added yourself to the list of people authorized to use it. (Sorry, I don't use sudo myself, and don't know how to set it up off-hand.)

sideburns gravatar imagesideburns ( 2013-12-18 22:23:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-18 04:07:42 -0600

boyd gravatar image

Sudo wants your password, not the root password. That said, since you can log in as root, run visudo and uncomment this line:

%wheel  ALL=(ALL)       NOPASSWD: ALL

Then add yourself to the wheel group.

usermod -a -G wheel username

You can then run sudo commands without a password. Of course this may not be appropriate in an envrionement requiring higher security, but makes your life more enjoyable on a personal machine.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-18 08:13:31 -0600

Seen: 2,850 times

Last updated: Jul 18 '18