Ask Your Question
0

Playing wmv files in Fedora 19

asked 2013-12-15 23:56:19 -0600

Marundu Muturi gravatar image

updated 2014-09-28 10:42:12 -0600

mether gravatar image

I am having trouble playing wmv files on my XFCE Fedora 19 32-bit installation.

Why wmv, you ask? Well, there are these Ethical Hacking videos I downloaded and this is the format they came in.

I have installed all the requisite plugins, yet even VLC cannot open these files.

The alternative would be to convert them to avi or some such format but I would like to know if there is a workaround.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-16 04:30:29 -0600

aws gravatar image

Enable rpmfusion.org repositories, (simple command line instructions on their website), then type sudo yum install gstreamer* in a terminal. This will install all of the "ugly" gstreamer plugins for playing patent-encumbered codecs using any media player that uses the gstreamer backend, such as totem or parole, which works perfectly fine on all of my fedora 19 boxes. [Of course mplayer or xine also play them perfectly, installable from rpmfusion]. Anton.

edit flag offensive delete link more

Comments

Hello, Anton. gstreamer is already installed and updated.Still, nothing. This is a snippet of the error I'm getting trying to install it again:

Marundu Muturi gravatar imageMarundu Muturi ( 2013-12-16 06:07:50 -0600 )edit

VLC plays the files in Windows, so I can't figure out what the issue is. Totem still gives the same error, that no suitable codec has been found.

Marundu Muturi gravatar imageMarundu Muturi ( 2013-12-16 07:47:00 -0600 )edit
1

answered 2013-12-16 04:33:18 -0600

cobra gravatar image

updated 2013-12-16 05:53:15 -0600

If VLC cannot handle them, then I'd worry whether the files are corrupted or do not contain what they purport to contain.

What 3rd party repository do you use for media libraries? If you have rpmfusion.org set up, then you can try installing all the GStreamer extensions, including the 'non-free', 'ugly' and 'bad' ones to see if you can get the files to open in totem.

Another thing that's worked for me in the past is to rename the files to .avi, and see if they can be recognised somehow in that way - it seems to make the player try different libraries to see if they can handle it, and it only works in extreme cases (but you might be lucky).

Also, you might find that the file have simply been corrupted during the download, and you only need to download them again, or find a host that will stream them for you.

edit flag offensive delete link more

Comments

"If VLC cannot handle them" <-- very correct point. "GStreamer extensions, including the 'non-free', 'ugly' and 'bad'... see if you can get the files to open in mplayer or xine" <-- mplayer and xine do NOT use the gstreamer libraries at all. They use their own. Only gstreamer based multimedia players, such as totem or parole, etc use gstreamer plugins. "corrupted during the download" <-- very possible, almost likely. "rename the files to .avi" <-- may work, but most gnu-linux systems ignore file-name extensions and examine first few bytes of data contents.

aws gravatar imageaws ( 2013-12-16 04:41:12 -0600 )edit

"mplayer and xine do NOT use the gstreamer libraries at all" - just goes to show that I do NOT use mplayer or xine at all... I exclusively use vlc these days ;). I stand corrected, I'll update my original comment. The renaming thing is something that I've done in the past - while Linux doesn't use the filename, I've seen it used to provide hints when a file couldn't be opened. This was a long while ago, of course.

cobra gravatar imagecobra ( 2013-12-16 05:50:33 -0600 )edit
0

answered 2013-12-16 06:11:54 -0600

Marundu Muturi gravatar image

Hello, Anton. gstreamer is already installed and updated.Still, nothing. This is a snippet of the error I'm getting trying to install it again:

 Error: Package: gstreamer1-plugins-ugly-devel-docs-1.0.6-2.fc19.noarch (rpmfusion-free)
           Requires: gstreamer1-plugins-ugly = 1.0.6-2.fc19
           Installed: gstreamer1-plugins-ugly-1.0.9-1.fc19.i686 (@rpmfusion-free-updates)
               gstreamer1-plugins-ugly = 1.0.9-1.fc19
           Available: gstreamer1-plugins-ugly-1.0.6-2.fc19.i686 (rpmfusion-free)
               gstreamer1-plugins-ugly = 1.0.6-2.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest 
edit flag offensive delete link more

Comments

You should give mplayer a shot; install smplayer or gnome-mplayer (which are GUI frontend for mplayer) and try playing one of those files.

Ahmad Samir gravatar imageAhmad Samir ( 2013-12-23 08:42:08 -0600 )edit

Wow, I'm sorry that I forgot to come back here and check again. The above error is the "type" of thing that has happened to me before. You have two different versions of libraries installed. You don't need the devel-docs [unless your going to write programs], and --skip-broken OR just install gstreamer1-plugins-ugly-1.0.9-1.fc19 and not use the wildcard, which is pulling in the docs. Also just occured to me, you already have the gstreamer1-plugins-ugly installed. Your media player is likely still using the gstreamer0.10 plugins and they may not be updated to include the "ugly" ones, needed for wmv's. Can remember how to tell totem which gstreamer to use. Both gstreamers are parellel installable. XFCE uses gstreamer0.10 and gnome uses newer gstreamer1.0 media framework. Try mplayer -framedrop -cache 8192 "filename.wmv" on the commandline. Try 'sudo yum install mpv' also, a GREAT ...(more)

aws gravatar imageaws ( 2014-08-14 14:39:32 -0600 )edit

Question Tools

Stats

Asked: 2013-12-15 23:56:19 -0600

Seen: 3,255 times

Last updated: Dec 16 '13