Ask Your Question

GRUB2 Colemak Keymap Default

asked 2013-12-05 20:35:41 -0500

SeanA gravatar image

I've looked for solutions everywhere and I can't find a suitable answer. I have read the posts here and Google. I will offer what I have on my current problem and thank you for taking time to read this.

Fedora19/32 runlevel 3 (boots to command line)

I have manually at boot hit E and changed boot parameter to en-latin9 and

I have edited /etc/default/grub to include these changes at every boot. After I save changes to file I run "dracut -f" and "grub2-mkconfig -o /boot/grub2/grub.conf"

I verify the changes are kept by hitting E at boot.

Yet no matter what when I try to enter my root user it has reverted to qwerty. After I login with the qwerty layout I then run "loadkeys en-latin9" and I am successfully switched to colemak. I then run startx and kde loads with my colemak layout as default.

setxkbmap only works for X windows environment and what I'm looking for is upon boot when I first enter my username the keymap is colemak.

any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-12-07 04:45:19 -0500

SeanA gravatar image

updated 2013-12-07 04:48:21 -0500

Ok, so after really looking into this it seems that the default xkb layouts are somewhat to blame. I even tried to create a custom layout to solve my problem.

The solution was actually much simpler and I knew that I was probably tackling this from the wrong point.

First create /etc/rc.d/rc.local

touch /etc/rc.d/rc.local

Make sure you don't have this file first of course.

The first line must be:


Then you just add the correct commands below that line:

loadkeys en-latin9


I added the echo COLEMAK so I could quickly dmesg | grep COLEMAK if I had a problem with the script at boot.

I hope this saves someone the time and frustration I experienced.

edit flag offensive delete link more

Question Tools


Asked: 2013-12-05 20:35:41 -0500

Seen: 389 times

Last updated: Dec 07 '13