Ask Your Question
1

vikrant is not in the sudoers file. This incident will be reported.vikrant is not in the sudoers file. This incident will be reported.

asked 2013-12-04 07:02:55 -0600

Vikrant gravatar image

updated 2013-12-08 03:13:21 -0600

FranciscoD_ gravatar image

i am getting this error whenever i try to install any software on my fedora 19..please guys help me out..i am new to fedora and the whole linux world ...

edit retag flag offensive close merge delete

Comments

1

It's difficult to give a confident answer without knowing your overall *nix competence. To enable sudo for the 'vikrant' user, a file needs to be edited or a separate one created. In addition, there is fine-grain control with sudo permissions, but perhaps that's not important to you. Have you looked at the man pages for sudo, sudoers, and visudo?

rickhg12hs gravatar imagerickhg12hs ( 2013-12-04 07:23:16 -0600 )edit

please provide more info, which software you want to install and if there is a bug then how you reproduced it

Akshay gravatar imageAkshay ( 2013-12-04 08:46:19 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-04 18:25:21 -0600

jmt gravatar image

When installing the system, you probably didn't make your username an administrator. That cat easily be corrected without editing the /etc/sudoers file directly.

Become root (you remember you root password, don't you)

su -

Make your own username an administrator (add your username to the group "wheel")

usermod -G wheel vikrant

Now exit the root shell with Control-D or the command "exit"

You might have to close you current shell session in order to get the elevated rights.

edit flag offensive delete link more
0

answered 2013-12-04 09:19:08 -0600

Instead of 'sudo yum install package', try pkcon install package

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-04 07:02:55 -0600

Seen: 3,338 times

Last updated: Dec 08 '13