Ask Your Question
0

removal of latest kernel? [closed]

asked 2013-11-29 04:44:09 -0600

catout gravatar image

I am running Fedora 18 and wish to remove the last two kernel updates because they cause a long dely in shutting down. I find myself anxious to scroll down to the penultimate kernel at boot in order to avoid this. First, is this safe? And secondly, how should I do it? Many thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Akshay
close date 2013-12-01 16:31:19.461028

5 Answers

Sort by » oldest newest most voted
1

answered 2013-12-01 10:22:31 -0600

jmt gravatar image

updated 2013-12-01 10:25:40 -0600

One of my machines behaves badly on some kernel versions so if after a kernel update I find some problems, I boot into the previous working kernel, remove the latest kernel and prevent that kernel from re-installing with line like

exclude=kernel-PAE-3.11.8

in /etc/yum.conf

Actually, on this particular machine I had to skip kernels 3.9 and 3.10 and stay with 3.8 until 3.11 was released.

edit flag offensive delete link more
1

answered 2013-11-29 10:12:08 -0600

skytux gravatar image

It is not safe to stay with only one kernel and remove the other two. Please, set your default kernel to be the last installed kernel, and keep the other two to use in cases when the system can't boot or wathever.

Follow the steps here to set your default entry:

http://fedoraproject.org/wiki/GRUB_2#Setting_default_entry

HTH,

Germán.

edit flag offensive delete link more
1

answered 2013-11-29 06:04:56 -0600

updated 2013-11-29 06:09:53 -0600

You can list the installed kernels with:

rpm -q kernel

and then remove the unwanted with

rpm -e kernel-{kernel_version}

or

yum remove kernel-{kernel_version}

edit flag offensive delete link more
1

answered 2013-11-29 07:21:40 -0600

mrunge gravatar image

updated 2013-11-29 07:22:08 -0600

you might also add to yum.conf

exclude=kernel

to prevent re-installing or upgrading

edit flag offensive delete link more
0

answered 2013-11-30 23:41:48 -0600

catout gravatar image

Thank you for all for your answers, all of which are helpful. The problem persists with the latest kernel-3.11.9-100.fc18.x86_64 so I shall continue to use kernel-3.10....

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-11-29 04:44:09 -0600

Seen: 451 times

Last updated: Dec 01 '13