Ask Your Question
3

How do I connect remotely to a Fedora desktop?

asked 2013-11-10 17:37:52 -0600

philip_38 gravatar image

updated 2014-05-09 10:40:09 -0600

mether gravatar image

I am going through a nightmare to enable vnc-server in Fedora 20. It seems to have changed from earlier versions. Can somebody post a step-by-step guide? I need only to enable simple root access for a single user, for administration purposes. In Windows I use the vncviewer client. I thank you for your help.

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
4

answered 2013-11-11 14:38:47 -0600

Marc lml gravatar image

updated 2013-12-28 14:23:06 -0600

You need to install vino to enable Desktop Sharing.

yum install vino

Desktop Sharing can be configured by running Desktop Sharing Preferences or start vino-preferences as a normal user.

By default vino will run on port 5900. Don't forget to allow vnc-server in the firewall configuration.

Update for Fedora 20: screen sharing can be enabled at System Settings > Sharing.

The port can be changed by running dconf-editor as a normal user, browse to org > gnome > desktop > remote access. Here you can enter an alternative port at alternative-port and check use-alternative-port.

Again don't forget to allow the ports in the firewall configuration. I find it the easiest to edit vnc-server service and add the appropriate ports.

edit flag offensive delete link more

Comments

I would appreciate some guidance on how to "edit vnc-server" in Fedora 20. Thanks!

enzoma gravatar imageenzoma ( 2014-01-26 04:14:26 -0600 )edit

@enzoma For the firewall configuration in Fedora 20: via GUI: Activities -> Show Applications -> All -> Sundry -> Firewall
via console: firewall-config

Configuration: Change to Permanent [Note: Test in Runtime and change to permanent when you know it is good] Choose your zone for what zone you want to open the firewall ports to. Public is very broad so be aware of your security. On the Services list go down to vnc-server and check it.

That's all there is to it.

makkura gravatar imagemakkura ( 2014-05-08 21:29:33 -0600 )edit
2

answered 2013-11-11 04:21:52 -0600

cobra gravatar image

I believe the way vncserver is configured was changed for Fedora 19, and that those methods will still apply. Try the solutions out in this question:

https://ask.fedoraproject.org/question/29229/vncserver-setup-in-fedora-19/

edit flag offensive delete link more
1

answered 2014-05-09 10:18:44 -0600

DrLucidious gravatar image

updated 2014-05-09 11:17:34 -0600

vino is for Gnome. For KDE, I used tigervnc following the instructions on http://stufs4u.wordpress.com/2014/02/25/install-and-configure-vnc-server-in-fedora-20/

However, it did not work immediately and I still had to explicitly tell the firewall to except the desired port: http://forums.fedoraforum.org/showthread.php?t=208819

Furthermore, in order to not create a new remote desktop but actually connect to the one which is already there, use: x0vncserver -rfbport=5910 -PasswordFile=~/.vnc/passwd -display :0

edit flag offensive delete link more

Comments

DrLucidious where does one use the command you gave? ie: x0vncserver -rfbport=5910 -PasswordFile=~/.vnc/passwd -display :0 where does it go? in a file?

neuronetv gravatar imageneuronetv ( 2014-12-18 15:24:03 -0600 )edit

I find that using a tilde ('~') in the password file path does not work if you use the "-Paswordfile=~/.vnc/passwd" syntax. Using "-PasswordFile ~/.vnc/passwd" (no = sign) so the shell will expand the tilde works fine.

And you can run the command manually from a terminal window, or add it to whatever session manager your desktop environment uses. (I'm using XFCE, different from both Gnome and KDE, so I can't be specific here.)

swahl gravatar imageswahl ( 2018-09-07 09:01:21 -0600 )edit
0

answered 2014-01-01 22:21:45 -0600

dksamuel gravatar image

I also feel that the VNC setup in fedora 20 id different, please will an exper write a howto

edit flag offensive delete link more

Comments

It did change for Fedora 20. Vino above uses TLS security which very few vnc clients support so I do not recommend this path as most efficient.

I recommend following the vnc-server ( tiger-vnc ) instructions here: ( Carlos Cestero ) https://bugzilla.redhat.com/show_bug.cgi?id=987981 specifically the change from 19 on involves modifying /lib/systemd/system/vncserver@.service rather then copying a version to /etc/systemd/system/ and modifying the copy.

JamesS gravatar imageJamesS ( 2014-03-07 14:24:44 -0600 )edit
0

answered 2014-05-14 21:57:37 -0600

Mouse gravatar image

well, it takes me sometimes to make vnc server work on fedora 20 you can access vnc server with normal user, I can mange to access with root user To install VNC Server on Fedora 20

This is vncserver@:1.service that I use for root user

[Service]
Type=forking
User=root
ExecStart=/usr/bin/vncserver :1 -geometry 1280x1024 -depth 24
ExecStop=/usr/bin/vncserver -kill :1
edit flag offensive delete link more
0

answered 2013-12-27 20:57:49 -0600

scottro gravatar image

updated 2013-12-27 21:00:39 -0600

I have a page on this, mostly repeating advice I received on the forum. http://home.roadrunner.com/~computertaijutsu/rhvnc.html

ISTR that it's been like this since F17, and will go into RHEL7 as well.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-11-10 17:37:52 -0600

Seen: 67,081 times

Last updated: May 14 '14